1

I know this may sound like a duplicate of Stop PowerPoint from changing proofing language to keyboard language but the solution there doesn't seem to work.
I have Windows 10 20H2, build 9042.867 and PowerPoint v.2103.
My system language is English, and I have Russian installed as well.
My presentation is in Russian, but when I try changing the proofing language to Russian, it changes back to English within like a second. I have moved the auto detection to the bottom of the Spellcheck list in options, and Russian to the top. It doesn't help. I have tried changing keyboard layout, but that didn't work either.

1
  • 1
    If you change proofing language it affects only current paragraph. You need to change global/template language. Global: File >Options >Language then select your desired language (Russian) as default. (It's availible from Revision>Language>[The second from drop-down] too)
    – Lluser
    Apr 20, 2021 at 8:06

4 Answers 4

1

I managed to solve this! It is not a PP problem, it depends on the input language keyboard. You are using the English keyboard in Windows 10 and that is why it keeps "smart" changing it to English. But you can change the keyboard of your preferred language.

  1. Click on keyboard language on the bottom right part of the screen (ENG)
  2. Language preferences
  3. Under Preferred languages click Russian and then options
  4. Add keyboard -> English (I guess your physical keyboard is English)
  5. Delete the Russian keyboard from the Russian language
  6. Now go back and move Russian as TOP preferred language

Now you are writing in Russian but the keyboard is English! So PowerPoint won't change it when you set it to be default Russian in PowerPoint!

1
  • This definitely is PowerPoint problem. It's their developers' decision to auto-match proofing language to your keyboard layout (a feature not found in other Office components). BTW: You can acheive your solution much faster by pressing Win+Space until you set your keyboard language to desired one (Russian in your case). Or you can override default input method in your system. See my answer below.
    – trejder
    Jun 19 at 15:09
0

Go to File- Options- Language- make sure 2 options are all set to Russian language: enter image description here

1
  • This answer is not correct (changing display language has nothing to do with the proofing language) and in my case inaccurate (changing authoring language in second list is correct, but in my case didn't solve the problem). PowerPoint is matching slide's language (proofing language) with your current keyboard layout and that is what you must change. See my answer below.
    – trejder
    Jun 19 at 15:03
0

I found both answers here to be incorrect or not enough. In my case to solve this problem I had to change current keyboard layout to the language that I want to use in PowerPoint.

This could be achieve temporarily, by pressing Win+Space that many times until selected keyboard layout matches your desired proofing language:

enter image description here

After that PowerPoint will auto-match proofing language to your selected keyboard layout.

You may try to force-set this permanently, by changing selection Use language list (recommended) to your desired language in Time & language → Typing → Advanced keyboard settings:

enter image description here

But I found this not permanent / not working at all and must use first solution each time I use PowerPoint.

Source: Prevent PowerPoint from auto-changing typing language.

0

There is a permanent answer here, please upvote it if it works for you, it took me a very long time to find it: https://superuser.com/a/1652362/1130787

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.