0

I was configuring my VirtualBox preferences and fixing a problem (regarding different extension pack versions; irrelevant) when I suddenly realized that even though I fixed my original problem I suddenly could not connect to the VirtualBox website from my host computer.

I know that while fixing my original problem, I was still able to connect to the website.

I then tried to enter the following commands:

C:\Users\Admin>ping virtualbox.org

Pinging virtualbox.org [137.254.60.32] with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 137.254.60.32:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

C:\Users\Admin>ping download.virtualbox.org

Pinging e2875.d.akamaiedge.net [104.101.26.154] with 32 bytes of data:
Reply from 104.101.26.154: bytes=32 time=109ms TTL=57
Reply from 104.101.26.154: bytes=32 time=114ms TTL=57
Reply from 104.101.26.154: bytes=32 time=103ms TTL=57
Reply from 104.101.26.154: bytes=32 time=107ms TTL=57

Ping statistics for 104.101.26.154:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 103ms, Maximum = 114ms, Average = 108ms

So I definitely have a slow yet working Internet connection. I tried uninstalling VirtualBox and the drivers, resetting my network adapter, clearing my DNS cache and restarting my computer yet I still can't connect to the website. I know that my hosts file is in mint condition so it might not help.

Machine information:

  • OS: Windows 7 x64
  • IPv4 DNS: 8.8.8.8
  • VirtualBox version: 6.1.18-142142

Are there any ways to solve this? Thanks in advance :)

Edit: I tried using a VPN, and it worked. But I still want to know how to fix it without using one.

4
  • 1
    Can you try a different browser? The link you supplied works fine in Kali / Firefox and in Windows 7 / Chromium Edge.
    – John
    Apr 21 at 2:11
  • I can't connect, regardless of browser.
    – skidipapa
    Apr 21 at 2:12
  • 1
    It's normal that you can't ping it since the host doesn't seem to reply ping anyway. curl -L works fine for www.virtualbox.org here. Therefore, if you want to test anything you are trying, stop using ping.
    – Tom Yan
    Apr 21 at 5:54
  • Also if you can connect other public host, then it could be your ISP acting up as well.
    – Tom Yan
    Apr 21 at 5:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.