0

When using RDP with the option "use all my monitors" on a 4K primary display and 1080p external monitors, the second (and third) displays are scaling incorrectly and cutting off.

The only workaround is to either use a single display (disable "use all my monitors") or set resolution of the primary display to 1080p.

I could not find any solutions to this. Does RDP (latest win10) on a 4K res primary monitor not support proper scaling to external monitors ?

1 Answer 1

0

Have you tried using PRemoteM? It has some fixes for session with combination of monitors with different resolutions and zoom levels.

Another one suggested solution is to edit .rdp file with notepad. Try changing "screen mode id:i" parameter to 2. Additionally you can try to experiment with "winposstr" parameter. Look in paragraph "Calculating the Values for winposstr".

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .