1

We are running Fortis Document Management Systems by Westbrook Technologies, and have recently run into an issue. Whenever we try to print a document in any way (even simply printing to PDF), an error occurs:

An access violation occurred at 0x#######(0x#######) in module FMPRINT.DLL. The product must now exit.

The entire application then proceeds to close. The individual workstations do not have FMPRINT.DLL. I tried adding it to one of the workstations' system32 as well as the fortis folder to no avail. The users also have permissions to the DLL on the server. Even when I performed a clean install on my own workstation, I cannot print.

All workstations are running on Windows 10, but were able to print on Windows 10 up until a few weeks ago - I am not sure what could have happened to change this. The issues began on 3/29, but was working up until then after the windows update we pushed on 3/21. Running it in compatibility mode for Windows 7 did not work.

Since it is out of support, contacting them directly is out of the question, although unfortunately so is working with a different document management system.

What is this error actually trying to tell me, and what can I do to fix it?

2 Answers 2

1

This bug is described in this Docuware support article
When printing out of Fortis we're getting "An access violation occurred at "" in module FMPRINT.DLL. The product will now close" after applying Windows Update KB5000808.

The answer as given is:

To fix the issue, apply KB5001649 - https://www.catalog.update.microsoft.com/Search.aspx?q=KB5001649
This isn’t a patch that is automatically applied, so it has to be manually installed.

Another workaround is to export the document first, then print the document outside of Fortis.

I suppose that a future version of Fortis will fix the bug, but until then these workarounds are the only solution.

1
  • So I installed the patch on my machine, and it worked. So I'm going to mark this as the solution. However, the machines having issues are on 1909, so unless I can find a patch for that specifically, I'm going to need to upgrade them, which shouldn't be too big of an issue. Thank you! Apr 26, 2021 at 12:59
1

All workstations are running on Windows 10, but were able to print on Windows 10 up until a few weeks ago - I am not sure what could have happened to change this.

Windows 10 has one or two significant updates in the last "few" weeks. So Windows 10 is changing and will continue to do so.

Westbrook is still around. Have you contacted them for a newer version? That would likely be less expensive than converting to a new Document Management Vendor.

I think you will have to do one (upgrade current) or the other (change vendors).

Followup note: Updates since February are cumulative (new update process): KB500802, KB5001330, KB500842 and KB5001649

Because of the change in updating, Microsoft said (Windows Insider issue) that ... it is no longer possible to officially disable and hide individual updates.

Another thing to try is printing the document outside of Westbrook; that is, save it locally and print.

3
  • @TheLittlePeace - There has been a recent update that broke printing for a lot of Windows 10 users, and Microsoft has spent the better part of 2 months, trying to fix it without success
    – Ramhound
    Apr 23, 2021 at 22:41
  • You were right - it was a Windows update that broke it. I appreciate your help, but I accepted the other answer as it was more concise and lead me directly to the solution. Apr 26, 2021 at 13:01
  • I am pleased you have it sorted out. That's great.
    – John
    Apr 26, 2021 at 13:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.