3

I've created a simple apl file with a function for evaluating a polynomial:

polyval ← {+/⍵×⌽⍺*(⍳≢⍵)-1}

(note the newline at the end)

When in Notepad++, if the cursor is currently at the end of the first line, many of the unicode chars render as boxes:

Unicode APL chars rendering as boxes

But when I place the cursor on the second line (empty), all of the characters render correctly:

Unicode APL chars rendering correctly

How can I get the characters to render correctly, regardless of which line the cursor is on?

Edit for future visibility: This occurs whenever the cursor is adjacent to a matched set of braces.

7
  • I can't reproduce this; what font are you using in np++? Commented Apr 26, 2021 at 15:44
  • This happens when the cursor is just before or after the braces. Ask Notepad++ developpers.
    – Toto
    Commented Apr 26, 2021 at 15:44
  • I'm using the default font that it decided to use on my system - Courier New
    – JPeroutek
    Commented Apr 26, 2021 at 15:45
  • Does this answer your question? Why does Notepad++ display some Unicode characters as square? Commented Apr 26, 2021 at 15:46
  • @Toto interesting observation, you're correct, it only occurs when the cursor is immediately before or after one of these chars: {}()
    – JPeroutek
    Commented Apr 26, 2021 at 15:46

2 Answers 2

3

The solution is to enable Direct Write in the MISC. Preferences window.

image of preferences window with correct option highlighted

I filed a bug with the maintainers over on Github, and this was the solution they recommended. Until there is another solution this will have to suffice.

1
  • 1
    Works for me ;)
    – Toto
    Commented Apr 28, 2021 at 8:18
0

This looks like a bug with Notepad++ having to do with the display of matched braces.

You will notice that the problem happens for these four characters: {, }, (, ). The bug has to do with the in-place display when writing the matched braces/parenthesis in red.

I haven't found a way to disable this feature, only of changing its attributes inside Settings > Style Configurator… > Global Styles > Brace highlight. But in any case, disabling it would be less than useful.

You may signal the bug in the Notepad++ Community.

1
  • I've filed a bug at their github repository; assuming there is no other resolution on the issue, this is likely the correct answer
    – JPeroutek
    Commented Apr 26, 2021 at 20:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .