I have a laptop, a HP 6910P with a Hitachi 160g 5400rpm Sata. This HDD drive me nuts since few hours because I hadded 1go of ram (3 total) in the laptop and since, issue over issues...

When I added the ram, I got a BSOD when I logged on Windows. Tried twice, same error. Removed the ram, same error. So I put the ram back in the computer and booted, got this error message:

C:\WINDOWS\SYSTEM32\CONFIG\SYSTEM is missing or corrupted.

So I tried to repair with the Windows XP CD. Fixboot worked fine but not with /mbr

I also tried chkdsk /r /p but I got the error message as soon as I hit enter:

The volume appears to contain one or more unrecoverable problems

So then, I decided to take another HDD and at the moment, it's being re-image

My issue is that now it's pluged on my PC with a SATA adapter and in My Computer, the HDD is only 10mb. In Disk Management, it's 160gb. Also, the HDD's name is not: Local disk (D:), it's a bunch of characters, the whole content is a list of folders that have weird signs and characters.


Make sure your memory is good. You can get memtest here or type "memtest" at the knoppix boot screen. Run it for 24 hours or until you get errors. If you get errors, take another stick or memory out and restart the process until you know that all the memory in the system is good. If any one of those sticks of memory is bad, your hard drive will become corrupt again. Check your memory first.

I would also recommend checking your hard drive's SMART status. You can boot knoppix, connect to the internet and run

sudo apt-get update

sudo apt-get install smartmontools

sudo smartctl -a /dev/sda

where the /dev/sda is the drive location from fdisk -l

If it fails the test, copy all the important files over to an external hard drive while booted in knoppix.

Before you do any more work on that hard drive, make sure to do a byte-for-byte backup. You can use dd as described here.

Then you can try going through Microsoft's solution.

  • The ram seems to be good because it's working fine now with the new HDD. The issue is with the HDD (160go) that I have connected with my USB-Sata adaptor on my workstation. Can't seem to recover any data. It's in fat12 right now. – r0ca Jul 16 '10 at 20:07
  • @r0ca Have you tried the testdisk undelete option or photorec data recovery? cgsecurity.org/wiki/TestDisk – James T Jul 16 '10 at 20:42

If there is no data you need, you can use Disk Management to delete the partition(s) and recreate to see if you get the 160GB disk.

Is it possible it is infected with some type of Malware? Have you scanned it with several tools while connected to your PC?

  • There is a lot of critical data on this HDD. It's a Lawyer's laptop so I need to recover a bunch of files before flushing it. I will try to scan it tho. – r0ca Jul 16 '10 at 17:45
  • Have seen good sucess with SpinRite Is the drive making any odd noises? Can you use the Check Now option under Properties Tools? grc.com/sr/spinrite.htm – Dave M Jul 16 '10 at 18:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.