0

I have two Windows 10 PCs on a home network. They access each others files via Mapped Network Drives. This basically works very well. However frequently File Explorer often takes a LONG time to load (20 seconds and often much more, sometimes hanging for over a minute). The Downloads folder and "This PC" most regularly cause problems, saying "Working on it".

  • if I disconnect the Mapped Network Drives then File Explorer works very well
  • both PCs have the identical problem
  • I am using standard Windows firewall & anti-virus software, unchanged from defaults.
  • I get the problem with both PCs on, or just one on (and mapped drives unavailable)

It may be worth noting that when I try to map a network drive, I have to type in the other PC's name otherwise it won't appear in Browse. I have enabled Network Discovery on both PCs.

One of the PCs is often sleeping which seems to cause horrendous timeout problems, but the problem occurs when they are both awake too.

I have had this problem for a year or so at a guess.

Both PCs are otherwise very fast and responsive.

5
  • You can set up the user name / password of the other computer (users and groups) on "this" computer and then share the folder you want to access using the user name you just set up. Restart and try access again and see if that speeds up access.
    – John
    Apr 29 at 17:41
  • Sorry but I don't quite understand what you are suggesting. Could you elaborate please? Currently the drives are mapped via each PC's Local Administrator account.
    – drb01
    Apr 30 at 8:20
  • On one computer (A) make a user and password (User and Groups) that is the user name of Computer (B). Now make sure the folder you want to access on (A) is shared to the user name you just set up on (A). Now map the drive (and folder) instead of browsing. This should be faster.
    – John
    Apr 30 at 11:20
  • Well A's local admin username is Mark. So I set up a user on B called Mark (and same password as on A), and I right clicked on a folder on B, and shared this to Mark with read/write access. Windows says to use the path "SyncM (file://M-2019/SyncM". But now A can't even connect to B using that path (and variations I tried). It sees B but says "Windows cannot access". I have messed about using different credentials and can't get it to connect at all. Hmm, this was so easy under Win7!
    – drb01
    Apr 30 at 14:12
  • I will post a working answer for you that I use to connect machines.
    – John
    Apr 30 at 14:15
0

Try the tested steps below. Check through all, although some settings may already be in place:

When connecting machines, Home Group is gone (security concerns), SMBv1 is gone, and Network Browsing at the Workstation level is sometimes not reliable. So I now use traditional sharing.

The following instructions enable folder sharing between two Windows 10 Machines.

Operating System Settings (Review the settings below or change as needed):

  1. Make sure Network Discovery and File / Print Sharing are enabled on both computers.

  2. Make sure password protected sharing is enabled both computers.

  3. Make sure both computers are in the same WORKGROUP.

  4. Make sure Wireless connections are Private, not Public.

Alternative to Domain DNS name recognition:

  1. If you wish to share by computer name instead of IP address, put an entry in the HOSTS file of the computer you are connecting from with the name and IP address of the main computer.

Setting up Sharing of folders:

  1. This next step depends on computer user names and passwords. If both computers use the same username and password, you can skip this step, restart both and test.

  2. If the user names are different, do the following:

  3. Make a username on the Main (Sharing) Computer that is the user name and password of the computer you are connecting from. Use this for permissions on the folders on Main (Sharing) Computer you wish to share. It is normally quite difficult to share USER folders because Home Group was removed and USER folders are heavily secured. Use a neutral folder for sharing.

  4. Again after all the above changes restart and test.

Testing the connection:

  1. On the computer you are connecting from, open a command prompt and type:

NET USE X: \name_of_sharing_computer\folder

  1. Press enter and then authenticate with the user name and password credentials.

If the connection attempt results in a numerical error, post that error back

3
  • Hi and thanks very much for that, this got things connected, and my initial impressions are that it is faster than before. But in particular the Downloads folder can take a long time (30s). There are 26 files in it! It seems if I leave the PC for a while (minutes, not hours) and come back the Downloads will do it's "Working on it", and after that it is nice and fast again. There are no shortcuts to networked files or anything so I rally don't get what is going on. Both PCs the same...
    – drb01
    May 1 at 9:51
  • Thank you for the update. My internal connection and transfer speeds are also fast. Downloads seem more a part of browsers and internet. I keep my download folders on all machines empty - download, let Defender check it, more it to where the file should be.
    – John
    May 1 at 12:12
  • I have redirected the browsers to download to a different directory not in c:\users\xyz\. This seems to be helping a lot for some reason!
    – drb01
    May 2 at 17:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.