1

Have been getting weird errors on my dev machine since the last windows update, exemplified by git failing to install :

first error

And also cryptovoxels website not working in chrome or edge (a 3D webgl site), but it is working in firefox. Do they use different rendering engines ?

I have tried a fresh install of windows but still get the same problems, is my cpu borked ?

All my hardware seems fine : memtest performed windows and mem96, intel diagnostic tool, ssd check - all passing without problem.

(apologies if this isn't the best place to ask)

Previously tried a restore Win 10, after april 14 update unuseable. RefreshWindowsTool.exe won't open, MediaCreationTool20H2.exe unuseable.

Seriously going to get a Mac.

7
  • "Do they use different rendering engines?" - yes. – gronostaj Apr 30 at 10:40
  • Did you try googling the error, as it appears application-specific? – JW0914 Apr 30 at 11:57
  • @JW0914 its not application specific. Numerous apps have failed in different ways, I've highlighted two that obvious and repeatable. Googling floating point error gets me, well nowhere useful. – NimChimpsky Apr 30 at 12:13
  • @gronostaj well thanks, I think. Care to elaborate on how they interact with windows/the cpu and what the differences are so I can track down the problem. – NimChimpsky Apr 30 at 12:14
  • 1
    I'm not that knowledgeable about exact differences, but it's enough to say that it's completely different code. Chrome and Edge use the Blink rendering engine and V8 JS engine, while Firefox uses Gecko and SpiderMonkey. They have nothing in common. – gronostaj Apr 30 at 12:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.