0

I have an Linux system with QCA9882 wifi carad adapter that runs wifi AP using hostapd. I've configured hostapd to use vht capabilities and enabled 80Mhz channel bandwidth. In general AP works but clients connects using 20Mhz channel bandwidth.

In particular my 2018 macbook pro connects to point, and after connection indicator shows that it switches between 20Mhz and 80Mhz for some time then stops on 20Mhz.

RSSI/Noize on client is -47dBm/-97dBm, there is no other visible 5Ghz stations.

How can I find out why clients can't use 80mhz?

UPD1: I did some test and find out that in my country (RU) I can run 80Mhz bandwidth access point only on 3 channels:

  • 36 (with center on 42/5210Mhz)
  • 149 (with center on 155/5775Mhz)
  • 153 (with center on 159/5795Mhz)

when running AP on 36 or 149 connected client use 80Mhz channel, but in case of 153 channel client prefer 20Mhz channel for some reason.

5
  • 1
    Manually set the channels on the QCA9882, then reconnect client (5GHz should either be on the highest DFS channel available or close to the highest channel available if non-DFS; in the US, non-DFS channel 157 generally performs the best w/ an 80MHz bandwidth). FYIs: it's not unusual for clients to use an 80MHz channel for download and 20MHz for upload; WiFi radios that clients connect to should always have their channels manually set and never set to auto, as auto will result in poor throughput performance (2.4GHz radios should be set to 1, 6, or 11 for optimal performance) – JW0914 May 2 at 12:22
  • Did you try to make an 80MHz network on channel 165? 165 is 20MHz-only. Are the clients connecting in 802.11a mode instead of n/ac/ax? Make sure you didn't disable WMM (802.11e, QOS-Data frames) or set your encryption to WEP or original WPA (TKIP)? N added 40MHz-wide channels, but requires WMM and forbids WEP and WPA (TKIP). – Spiff May 3 at 0:59
  • @Spiff no, I don't try to make 80MHz on 165 channel, problem with 153 channel – Kamil Zaripov May 3 at 16:05
  • @JW0914 It seems that QCA9882 already work on 80MHz channel and I can't how to make it "more 80MHz", can you explain how to manually set 80MHz on QCA9882? – Kamil Zaripov May 3 at 16:08
  • @KamilZaripov 5GHz uses the channel you set, plus an upper and lower, and IIRC 153 is the lower for 157 - try 157. Whether you can change the bandwidth [80MHz] or not depends on the radio's drivers, but 5GHz can operate with a 40MHz or 20MHz bandwidth as well (there's likely a usage scenario for doing so, but I'm unsure what it would be) - 5GHz always defaults to 80MHz, else throughput becomes extremely limited (50% for 40MHz, 25% for 20MHz) – JW0914 May 3 at 19:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.