In my case, where I really want it to be safe to the max, I SSH into my server with PuTTY, where it first authenticates with the ppk, then asks me for my password and my 2FA code. FileZilla on the other hand, if I choose key file, it says that further authentication is required, but if I choose Interactive it asks for my public key. The way around this is to first select Key file and then Interactive, as it caches the key apparently? But it is really annoying to do every time.

I do not need to use FileZilla specifically, I only need a GUI SFTP program.



1 Answer 1


In FileZilla, you do not need to specify the key per session. Assuming you share your keys across server (and even if you do not), you can specify the key(s) in global preferences by going to:
Edit > Settings > Connection > SFTP > Private keys

You can alternatively use my WinSCP SFTP client, which behaves more like PuTTY, but allows you to store your password. So you can specify your private key and password at the same time.

  • Yeah, thanks. I'm using WinSCP now, and it works like a charm. I didn't want to bother with FileZilla and WinSCP fulfills my needs. Thanks! Commented May 3, 2021 at 10:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .