0

I'm experiencing a really frustrating issue on my Windows 10 PC.

I lose internet access randomly during the day on my wired connection (Wi-Fi works just fine).

When this happens, the internet icon in the lower right corner remains the same, shows "Internet Access" and I get no error messages.

But when I try to open a website in a browser, it just hangs and after a while shows the following error: Screenshot

I've tried this in several browsers, including Firefox, Edge, Chrome, Brave and Vivaldi. No browser works, but Firefox is the only one showing an error message after a while - the other ones just hang.

One interesting thing I have noticed is that whatever game service I have running and downloading stuff when this happens, it can continue to download without issues. Most of the time this issue happens randomly, so regardless if I have any programs open or downloading anything, but for example if I'm downloading a game through Steam or Battle.net, I am able to pause and continue that download even after this issue happens. Interestingly enough, if I log out and try to log back in into any of those programs, I can't.

I've recorded the whole process with all the symptoms and error messages visible and uploaded to YouTube:

https://www.youtube.com/watch?v=g7M2OmggW4o

I tried using the ipconfig commands in CMD to fix this, namely release, renew and flushdns, as well as commands like: netsh winsock reset and netsh int ip reset, but these did not make any change.

Under Device Manager > Network Adapters I found my network adapter (Realtek PCIe GbE Family Controller), clicked on Properties and disabled the following: Energy-Efficient Ethernet, Green Ethernet and Wake on Magic Packet (as suggested in another post I found online). Again, this did not prevent the issue from happening.

I'm on Windows 10 Version 10.0.19042 Build 19042

My motherboard is: B450 TOMAHAWK MAX (MS-7C02)

I removed the network driver completely while in Safe Mode without network and installed the latest network driver and chipset driver from the official website for my motherboard, which is a B450 Tomahawk Max, and this did not change anything as well. I also tried the Windows built-in feature "Update Driver" and let Windows automatically install it's own driver after removing the old one, to no avail.

Finally, I tried using that same wired connection on my Linux powered laptop, using Pop OS. I've used the laptop for 2 days without disconnects.

This might mean something, but I want to point out that there have been periods when this issue did not happen for a few days at a time, but lately it's been happening 3-5 times a day.

I also tried setting up a static IP on my card and the same issue persists.

When this happens, I'm able to access my router settings at 192.168.1.1, so I'm guessing communication is being established correctly there. Also, Wi-Fi works all the time, which makes me thing that there's nothing wrong on my ISP's side.

The only thing that fixes the issue is if I:

  • restart my PC

  • go into the Device Manager and then disable and enable my network adapter.

I've spent weeks browsing all kinds of different forums and pages trying to fix the issue, but could not find anything that solved it for me.

I also called my ISP and they sent over a technician who tested everything out, concluded there are no issues on their side and replaced my router with a brand new one, for good measure.

Tech Support Guy System Info Utility version 1.0.0.9:

  • OS Version: Microsoft Windows 10 Pro, 64 bit, Build 19042, Installed 20201020141753.000000+060

  • Processor: AMD Ryzen 7 3700X 8-Core Processor, AMD64 Family 23 Model 113 Stepping 0, CPU Count: 16

  • Total Physical RAM: 16 GB

  • Graphics Card: Radeon RX 580 Series

  • Hard Drives: C: 222 GB (37 GB Free); F: 298 GB (85 GB Free); Q: 1862 GB (197 GB Free);

  • Motherboard: Micro-Star International Co., Ltd B450 TOMAHAWK MAX (MS-7C02), ver 1.0, s/n JB16610699

  • System: American Megatrends International, LLC., ver ALASKA - 1072009, s/n To be filled by O.E.M.

  • Antivirus: Windows Defender, Enabled and Updated

Any help would be much appreciated.

Please let me know if I can provide any further information.

Thank you so much!

UPDATE: I replaced my CMOS yesterday as suggested in another forum, but the issue persists today as well...

I did discover something interesting in the process - I can ping and tracert websites once the issue happens.

I've made another video showing this: https://www.youtube.com/watch?v=WixDO2Vi8Zo

3
  • See if there are interesting error messages in the Event Viewer.
    – harrymc
    May 3 at 15:19
  • I suggest at this point trying a USB Ethernet card and see it that solves the issue.
    – John
    May 3 at 15:50
  • Hello! I found nothing interesting in the event viewer and was also not able to replicate the issue with a USB ethernet card I borrowed from a friend. That said, this issue happens randomly, not periodically. I was able to find something interesting though - I can ping and tracert websites without problems once the issue happens. I've made a video showing this here: youtube.com/watch?v=WixDO2Vi8Zo
    – Olat
    May 4 at 7:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.