1

I'm trying to migrate to virtual and old physical machine with nvidia GPU.

I've succesfully done it with virtualbox with vmware graphics emulation, worked like charm after some tuning.

On the other hand I was using qemu/kvm anyway for my other projects, and the qemu/kvm does not seem to support this graphics adapter emulation (I can't pick it in virt-manager), although command-line qemu without kvm acceleation seem to support it.

I'd like to pick a different driver, but the guest (with 2.6.15 kernel) supports:

vmware nvidia fglrx vga cirrus

backporting qxl or virtio sounds like the best way out but sounds really tricky.

Is there a way to use vmware graphics in qemu-kvm?

0

Try editing the XML manually. (In virt-manager, you have to enable that first in Settings). You may also be able to just type into the dropdown box.

I have libvirt 5.0.0-4+deb10u1 and can manually enter “vmvga” and the VM starts afterwards. The resulting QEMU argument is:

-device vmware-svga,id=video0,vgamem_mb=16,bus=pcie.0,addr=0x1

I’m not sure this is the VMware virtual graphics adapter you need, there’s lots of them. It is the only one available however.

3
  • Yeah, It worked, thank You! I've tried editing it manually, I tried "vmware-svga" and "vmware", but I haven't tried "vmvga" - I have no idea how "vmvga" maps to "vmware-svga" but it... booted successfully. Although It gives me some artifacts in xserver, which did not happen in virtualbox, might be not enough memory? I'll try to work it out, but If You've got any tips what parameter to use in xml for this driver - tell me. – boskar May 6 at 9:35
  • After setting the model and committing the change, I ended up with vram="16384" on the <model> element. Just take a look at the XML again, the parameters are added automatically. 16 MiB could indeed be a little tight. – Daniel B May 6 at 13:49
  • I tried <video> <model type='vmvga' vram='131072' heads='1' primary='yes'/> <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/> </video> - after increase it helped a bit(?) but maybe it was random... Or maybe 128 MB is too much? – boskar May 6 at 16:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.