0

I have a number of emails in my Inbox with square brackets in the subject line.

I want to search for these in Outlook so I can see how many of those emails I have and what they are.

Outlook simply refuses to search based on a symbol.

I have searched a lot for a solution for this and keep being redirected to this Blog post: http://www.msoutlook.info/question/389

Which suggests that you can simply use the "Advanced search". However this DOES NOT work.

Searching for the word "Test"

Searching for the word "test" works as expected. And as you can see I have emails with the word [Test] as the subject and also with the word [ Test ] as the subject in the search results. (two in sent items, two in inbox)

Searching for a square bracket character

Searching for a square bracket character in that same inbox brings back no results

Searching for a square bracket character using "Advanced Find"

Using "Advanced Find" as per all the answers online, including a few on this site, doesn't work.

enter image description here

Using the "Advanced" tab in the "Advanced Find" menu, also doesn't work.

Tried on Outlook 2016 and Outlook 2019

I am losing my sanity trying everything for this. I can't believe that Outlook would deliberately ignore all special characters and symbols in every type of search, but it appears that it does.

2
  • 1
    In your Advanced Find dialog, did you include Search sub-folders? Or are the e-mails all in your Inbox, not in a sub-folder? May 5 at 15:28
  • The emails I'm testing with are in my Inbox May 6 at 14:15
-1

According to my tests, it could work normally like below:

enter image description here

But by default, it wiould only search the "Inbox" folder but not the subfolders under it. If your mail is actually located in a subfolder, agree with spikey, it's recommended to choose "Browser" and check the "Search subfolders" option to test.

7
  • The emails I'm testing with are in the Inbox folder. Interesting that it seems to work for you. If you go to "File", "Options" and "Search" in Outlook, is the "Indexing Options" button greyed out for you, and do you have a message asking you to "Upgrade to the latest version of search"? It seems that this issue only starts if you "Upgrade" to using "Windows Search" in Outlook, instead of Outlook's own built-in search. May 6 at 14:17
  • Nope, my Indexing options is normal and I could click it. I don't remember if I have upgraded windows search recently, but if the issue occurred after you update the windows search, it may be related to your windows search, it's suggested to rebuild the search index to check (Control panel>Indexing Options>Advanced>Rebuild)
    – Jade
    May 11 at 9:32
  • Yes, it is related to Windows Search. Rebuilding the indexes does nothing. May 12 at 12:43
  • Have you tried to run the windows search troubleshooter ? If that's invalid, we could also try to re-enable the windows search service to check, according to my experience, sometimes it could be helpful when I couldn't search normally.
    – Jade
    May 14 at 4:57
  • Of course I've tried running the Windows Search Troubleshooter. The Windows Search service is working normally and enabled. Once you've installed it disabling the service and re-enabling it changes nothing. May 14 at 10:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.