0

I do not understand this unexpected behavior: I'm making some experiments with VMWare Workstation 16 Pro and few virtual machines with Windows 10 Pro (20H2) and Windows Server 2019 Standard. I put Windows 10 machines on a domain and, for a while, I did not have any kind of trouble: I could click the Search Active Directory button in the Network window for opening the useful Find Users, Contacts, and Groups window. Now, without any kind of reason (I did not make any change and no computer has access to Internet) the Search Active Directory button is greyed out on all the computers, Server 2019 machine included enter image description here

I can open the Find Users, Contacts, and Groups window, digiting Rundll32 dsquery.dll OpenQueryWindow but how can I reenable that useful button? I do not want to install something on the computers, since the button had worked fine for a while on each computer.

MORE: Everything works fine: domain works fine and computers can see each others as usual: the only issue is about the Search Active Directory button and, repeat, no machine accesses to Internet and never I made updates

1
  • Has the machine installed any recent updates? If the machines have been updated, which updates specifically, have been installed? Are you positive that the machine and AD server can still communicate? Edit your question instead of submitting a comment – Ramhound May 6 at 19:17
0

Problem solved. I found the reason for that behavior: it is one of the limitations due to the fact that Windows is not activated: even if you install it without a serial key, you can use the o.s. without any limitations, until you do not access to Internet but, if the machine accesses Internet, even if for few minutes, then you have to activate Windows or you have to endure certain types of limitations like the inability to change background images or manage icons on the taskbar from Settings (you can do that but in another fashion, e.g. via Regedit or third-party tools). Anyway, one of these limitations is that the Search Active Directory button is greyed out. In my case, probably there was a moment in which machines went to Internet (but I do not remember) and, since I have installed them skipping serial keys, Windows wanted to be activated: from this moment on, the Search Active Directory button became greyed out. When I tried to activate the machines, the problem was fixed and the button is back.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.