I was using my virtual machine normally, but I did something to network settings and it is block my Wi-Fi when started up. I have a VMnet8 which equals to NAT. But when I am connecting it to Vmnet 8 virtual machine has not internet. With NAT it is same problem. That is why I used bridged. What am I doing wrong?

enter image description here


For the bridged connection, shut down the guest, go to setting for Network and uncheck "Replicate physical state" . Restart the test.

Also use the VMware Network editor to reset the NAT network (internal DHCP). You need to restart the machine after this.

Do the above, restart, make sure Wi-Fi is working, start the Guest and test.

  • Thank you so much for your attention. It worked. I restored to defaults from virtual network editor and it worked properly. – Rashad Aliyev May 6 at 21:08
  • You are very welcome. Happy to help – John May 6 at 21:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.