I want the Task Manager to be able start automatically each time when user login to the Windows. The following article describes how to Add an app to run automatically at startup in Windows 10:

  1. Select the Start button and scroll to find the app you want to run at startup.
  2. Right-click the app, select More, and then select Open file location. This opens the location where the shortcut to the app is saved. If there isn't an option for Open file location, it means the app can't run at startup.
  3. With the file location open, press the ⊞ Win+R, type shell:startup, then select OK. This opens the Startup folder.
  4. Copy and paste the shortcut to the app from the file location to the Startup folder.

I created shortcuts exactly according to the article above. The FireFox, for example, is starting without a problem, but the Task Manger don't.

My shortcut in the Startup folder:

enter image description here

UPDATE: As you can see in the shortcut parameters the Task Manager is starting in the minimized mode, but I can see it icon in the System Tray.

I also checked proposed solutions from the following posts:

Launch Task Manager as minimized to the tray on login

Task Manager Does Not Start Every Time

So, my question is “Why the Task Manager automatically does not start from the Startup folder on a user login”?

3 Answers 3


Well, it is possible to use the Task Scheduler to run the Taskmgr.exe at user log on. Unfortunately, when I minimize the application I don't see it icon in the System Tray area, what is required.

Therefore, I found the following solution:

  1. Created a .bat script file with one command: start /min /high C:\Windows\System32\Taskmgr.exe. The /min parameter says the Taskmgr.exe will start minimized.
  2. Create shortcut to .bat script file and put in under the Startup folder.

Now the TaskManger starts at user log on. It minimized and it is possible to see it icon in the System Tray area.


There are 3 thing going on:

  • It won't start from the Startup folder, because you can't give it admin privileges. This is a dead end.
  • It won't start from Task Scheduler (correctly), because when it starts, it starts too early, there is no desktop at that time. We need a 1s delay in Task Scheduler!
  • If you use a .bat/.cmd file, there will be a popup cmd window. We need a VBScrip 1-liner!


  • Create a "StartMinimizedHighpriority.vbs" in the System32 folder with this 1 line in it: CreateObject("Wscript.Shell").Run "C:\Windows\System32\cmd.exe /c start /min /high " & WScript.Arguments.Item(0), 0, False
  • Create a Task Scheduler task
    • with a "1 second" delay in the Trigger
    • with "C:\Windows\System32\StartMinimizedHighpriority.vbs" as Program and "C:\Windows\System32\Taskmgr.exe" as Argument in the Action
  • 1) You don't need administrator privileges to start the taskmgr from the Startup folder both for a standalone computer and for computer controlled by the Active Directory (AD). Especially when computer under the AD control the network administrators can easy configure these permissions by using the group policy.
    – Jackdaw
    Commented Mar 15 at 14:32
  • 2) When you are using the Task Scheduler it's necessary to make some delay before starting the taskmgr. For example, using timeout /T 3 command inside the batch file, before running the taskmgr. But applications from the Startup folder are started by Windows when the Desktop is active. Therefore, no reason to make a delay. 3) When the Run property for the shortcut (see the original question above) set to Minimized there is no cmd popup window. This parameter is using by many administrators to run script in background.
    – Jackdaw
    Commented Mar 15 at 14:38
  • 1
    Yeah, shortcut in the Startup folder doesn't require a delay, and you can set minimized on the shortcut, but you can't set the admin privilege, so it won't work. It worked in the past, but currently it doesn't work on Win 11. I've spent hours fighting with it, googling some solution, nothing worked, gave up. That's why I've used the Task Scheduler.
    – lmagyar
    Commented Mar 15 at 16:30
  • I see. I'm using my solution on the Windows 10. Thanks for the remark.
    – Jackdaw
    Commented Mar 15 at 16:34

Try this:

Open Task Scheduler. Click "New Task" Set a trigger to "at startup" or "at log on". Set an action to start taskmgr.exe Set to run on highest privileges Name your task. Set the task to run if the user is logged on OR NOT. Click OK. Enter your credentials, and click OK. It doesn't start in the "Startup" folder because Microsoft programmed it so system apps will not start in the "Startup" folder. If you try other system apps it won't work. Try asking in the MS help center.

  • Thanks! The task manager is started. Unfortunately, I did not find an option how to run it minimized state. Furthermore, when I minimize the application manually, I do not see it icon in the System Tray area, what I need.
    – Jackdaw
    Commented May 8, 2021 at 11:23
  • @Jackdaw did you press the up arrow in the system tray, drag its icon and click "Hide when minimized" in the Taskmgr?
    – s3246
    Commented May 8, 2021 at 13:47
  • I don't have up arrow in the system tray: all icons are visible.
    – Jackdaw
    Commented May 8, 2021 at 14:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .