0

I have 500mbps internet connection from Spectrum. Their modem goes to a wireless router which has 4 ethernet output ports. From those I go to an unmanaged switch, where I connect to my pc and get the full 500mbps.

However, from the switch, I connected to an access point in 2 different rooms and only get 80mbps. For testing purposes, I've replaced the switch and the access point and got the same result.

From the switch, using the same ethernet cable that I used to test the AP, I get the the full 500mbps on my laptop.

Bypassing the switch completely, connecting either AP tested to one of the ports on the wireless router, I get the full 500mbps. So something happens only to the wireless connection after the switch, not to the wired connection. I've used the Wi-Fi analyzer app and connected to all the best suggested channels, but this is where my knowledge of this ends and I could use some help. I've also updated the firmware where available, tried different ports and different cables.

The items are:

TP-Link TL-SG108 | 8 Port Gigabit Unmanaged Ethernet Network Switch

Wavlink WL-WN575A3 (AP)

Spectrum Wifi router Wave 2 Router Model RAC2V1S

Spectrum D3.1 eMTA DOCSIS 3.1 Advanced Voice Modem

1

The WL-WN575A3 access point only has 100 Mbps Ethernet ports.

I'm not sure about your tests, but I highly suspect that whenever you test a direct connection without a switch, you either end up connecting to the router and not to the AP – or you end up switching the AP to "extender" mode where it connects to the router via 802.11ac Wi-Fi and not via Ethernet.

Either way, it's not going to be able to squeeze 500 Mbps through a 100 Mbps Ethernet.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.