1

I am using MS Word 2016 version. I can't add "Space before paragraph" on the first paragraph of the second page. But if I press "Enter" before the paragraph, then I can add "Space before paragraph" but in that case, the space amount will not be exactly same (eg: 12pt) as there is one manual spacing from the "Enter" at the beginning.

But surprisingly I can add "Space before paragraph" at the first paragraph on the first page without any problem (without giving any "Enter" at the beginning).

What is the solution for this problem? Please note that the "Suppress extra line spacing at top of page" is not checked from the Options>Advanced>Layout.

Here is the problematic MS word file for your reference:

https://www.dropbox.com/scl/fi/lzjh42ljkumdii0c5ezbq/before-spacing.docx?dl=0&rlkey=c5fd9amzwddde02anmz6xzkw6

The screenshot of my page with options: enter image description here

2
  • How did you "end" the text on the first page? Did you use a page break?
    – Albin
    May 9 at 18:23
  • Yes, I have added a Page Break May 10 at 7:40
1

You can put a Frame into the style that you want to have that spacing.

Some time ago, Microsoft changed Word so that the space-before is ignored at the beginning of any page except the first page in a section. This is true no matter how the page is begun, except with a Section break. It is not advisable to use a Section break just to handle this spacing. When a Frame is used, the Frame starts at the top of the page but the space before takes place inside the Frame. Frames can be invisible.

Here is my page with directions on how to create a Frame as part of a style.

Using Frames to Provide Space Before a Heading after a Page Break (Column Break)

In recent versions of Word, Frames are required to provide space before the heading starting a new chapter after a page break or a

column break. (Note: this is a problem with a page break or a column break, but not a page break inserted as part of a Section break.)

By design, Word ignores the space setting for the paragraph without the Frame. The same thing happens with a column break. Word

ignores the Space-before formatting of a paragraph style (or just paragraph formatting) when the paragraph is the first one on a page following a page break (or at the top of a column following a column break). You can use a Frame to get around this. The simplest method is to modify the Style: screenshot of dialog box You would want a borderless frame and to have the space-before paragraph formatting that you need.

screenshot of dialog box

Excerpt from my page on Frames and Textboxes in Microsoft Word

By the way, your sample had no space-before set. Here is your document back with Heading 1 style being used and a Frame. Here is a temporary link and screenshot. The Frame shows up when text within it is selected. It does not print and does not appear when you are working outside the Frame.

Screenshot from repaired document

You can add Page-Break-Before paragraph formatting to the style, also, if you want. This eliminates the need for the manual page break and makes editing easier. Applying the (heading) style automatically starts a new page.

Here is my writing on the importance of Styles in Word. Here is Shauna Kelly's page on how using the built-in heading styles can make things easier.

This answer applies to all versions of Word, although using Frames for this purpose is not necessary in the menu versions (Word 2003 and earlier).

1
2

It's not possible without a workaround. There used to be a compatibility option Suppress Space Before after a hard page or column break which you could turn off. This is not the case any more in version 2013 and up.

There are several workarounds though, depending on the the type of text at the beginning of the page. E.g. if it's a heading you could use this solution: How to add space before a heading in Word 2013 and 2016, but if you do a search you can find several other ones as well.

"Easiest" Workaround would be to add the space manually. Since the problem will only occure after a page break there shouldn't be any complications with the manual space addition.

8
  • I have added the real file link in order to download and check the options which you are referencing. Please download and examine the file options and let me know. Thanks May 10 at 10:50
  • @AbdullahMamun-Ur-Rashid Sorry, I don't download MS office files from external sources. But I was able to replicate the problem with the current version. So there's no need to download the file.
    – Albin
    May 10 at 14:01
  • but I did not put checkmark on "Suppress Space Before after a hard page or column break" from the Options>Advanced in MS Word. May 10 at 15:27
  • @AbdullahMamun-Ur-Rashid do you have that option? can you post a screenshot?
    – Albin
    May 10 at 18:36
  • I have added the screenshot. Please see my updated Question. May 11 at 6:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.