I wanted to connect to my Unix server using SSH keys. For that I had converted my id_rsa file from ./ssh directory to a ppk file using PuTTYgen, but after loading my .ppk key I get this warning:

PuTTY key format too new

enter image description here

If I use my default id_rsa file, then I get error:

OpenSSH SSH-2 private key (old PEM format)

Either way I am getting stuck. Can anyone please help me?

7 Answers 7


Easy way to fix this issue, please follow the pictures.
enter image description here Step2:
enter image description here

  • 1
    After getting the same error, then doing this, I now get from Pageant "Couldn't load this key (Open SSH SSH-2 private key (old PEM format) - a rock and a hard place
    – PandaWood
    Apr 21, 2022 at 4:25

If you have a key in the new PPK version 3 format, you can use PuTTYgen to export it to the old PPK version 2 format.

I don't know what Operating System you're using PuTTYgen/PuTTY on, but if it's Microsoft Windows you can set PPK Version 2 by default for PuTTYgen selecting in the app menu:

Key->Parameters for saving key files... ->PPK file version: 2

PuTTYgen: Private Key File Parameters

  • I tried to load it in PuTTYgen, but it also says "too new"
    – Black
    Sep 17, 2021 at 10:40
  • 1
    @Black You need to use the latest version of PuTTYgen. What makes sense only, if you are stuck with old version of PuTTY on some system, where you need to use the new key. You can download the new version of PuTTYgen on another system, convert the key there, and copy it to the system with the old PuTTY. If you are free to use newest software directly, then go for latest version of PuTTY, and you won't have to convert anything. Note that the OP created/converted the key with latest PuTTYgen, but is trying to use it with old PuTTY. See my answer. Sep 17, 2021 at 10:53

You have probably used a newer version of PuTTYgen than the version of PuTTY.

There's new PPK format since PuTTY 0.75 (released 2021-05-09). So I guess you have used PuTTYgen 0.75 (or newer) to convert your key. But you are trying to use it in an older version of PuTTY.


I've put newer version of puttygen.exe and pageant.exe in TortoiseGit\bin folder and it works

  • By the time I got here, I had already setup keys. Replacing the outdated Tgit ones worked well.
    – Machavity
    Jun 4, 2021 at 21:27

Install the Latest version of putty at least 0.75 it will work fine


Had a similar issue,

  • key generated with PuTTYgen 0.75
  • works fine with PuTTY 0.75
  • fails with tortoiseGit (format too new)

After reading answer by @martinprikryl

  • changed in TortoiseGit->Settings->Network->SSH client to PuTTY's plink - and it works again

If you don't want to or you can't upgrade due to security policies on your computer, you can download the binary for the newer puttygen.exe, run the binary and load your .ppk file. Once loaded, go into "Conversions" and select "Export OpenSSH key" and save as a .pem extension.

Next, using the older puttygen, go into "Conversions" and import the .pem file you generated. Once loaded, "Save private key" to a new .ppk file.

At this point you should be able to use the older putty.exe file to connect to your host with the .ppk file that you saved.

You can verify, assuming you have the .pub file, by saving the file as a new public key and compare the signatures between the 2 .pub files. The public key signatures, from my experience are the same.

Or as some has already stated, load your .ppk file, go into: Key -> "Parameters for saving keys files ..." and select PPK file version 2 and "Save private key".

  • So why would you mess with two versions of PuTTYgen, if you can do it with the new version of PuTTYgen only? Aug 31, 2021 at 17:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.