0

I've got 2 SSDs, one for Windows and one for Linux Mint. I have another 4 HDDs I turned into a RAID 0 array via my BIOS. Mobo is ASUS TUF X570.

I had the 4 HDDs in a Microsoft storage pool but started to get poor read/write speeds and was being generally a bit flaky. I deleted the pool and removed the drives from it. Booted into my BIOS and created the array, part of which meant changing the SATA operation from AHCI to RAID.

Booting into Linux (my daily driver) everything was fine. Booting into Windows I was met with blue screens saying that it doesn't know where to boot from, even though the SSD that windows was installed on hadn't been touched.

I've followed numerous guides. Changing back to AHCI and booting into windows (which did work), setting it to boot to safe mode and switching it back to RAID during the restart, again blue screen. As well as some registry edits and still blue screens.

I gave up and decided to re-install windows to the same SSD but I keep running into a prompt where it says there are missing drivers. My assumption is that there shouldn't be any missing drivers if the RAID is set up on the BIOS?

I gave up with that too and went into Linux and formatted the drive to make sure that wouldn't be an issue and then initialised it with NTFS. Again, when I went to the install process of windows I got the same missing drivers issue.

I've tried disconnecting all the HDDs that make up the array with no change in behaviour.

I thought I was onto a winner looking through RAID software that comes with the mobo, specifically pages 52-54 and following the instructions. I just kept getting the equivalent to 'Failed to load drivers'.

I've tried during the install process of Windows going into the command prompt to use diskpart to see if my drive is even listed, which 99% of the time it isn't. If I change to ACHI mode it's listed. If I stay in RAID mode and try, it gets listed once I try AND fail the install of the drivers.

One thing to note, perhaps. My boot priority is that it's Linux and then in the grub menu I added the windows drive so that I can choose what OS to boot into at that point. I can't imagine this would be the reason for the errors I'm running into but I'm just clutching at straws now.

I'm frankly not sure what I can even do anymore, nothing seems to work.

EDIT: For clarity: I'm not able to boot into Windows as I no longer have it installed. My aim is to install Windows whilst having RAID set as the sata operation. I want to install Windows onto 1 of my SSDs that is NOT apart of the RAID array. The end goal is that I have Windows installed on an SSD and then my HDD raid array will be used for storage.

10
  • 2
    It’s tough to understand your question. Are you currently able to boot into Windows, or because you attempted to reinstall Windows without the proper RAID drivers, are you unable to boot into Windows? Unless you are installing Windows on a RAID array you shouldn’t be enabling RaID mode within UEFI.
    – Ramhound
    May 10, 2021 at 11:10
  • I'm not able to boot into Windows as I no longer have it installed. My aim is to install Windows whilst having RAID set as the sata operation. I want to install Windows onto 1 of my SSDs that is NOT apart of the RAID array.
    – shmink
    May 10, 2021 at 12:08
  • Can you not have the sata operation set to RAID and install windows on a non-raid drive?
    – shmink
    May 10, 2021 at 12:10
  • 1
    Does your system even have a raid controller? Storage pool is a software RAID solution (it’s not actually a RAID solution technically). What problem are you trying to solve by installing Windows with RAID mode enabled (since it won’t help with storage pool performance)
    – Ramhound
    May 10, 2021 at 12:13
  • 2
    If you enabled RAID mode, then you must provide Windows the RAID driver, even if you are not installing Windows on the RAID. Just to confirm, when you were prompted for a RAID driver, you provided the RAID driver listed on this page? RAIDXpert2 is required once you have already installed Windows. "My assumption is that there shouldn't be any missing drivers if the RAID is set up on the BIOS?" - Your assumption is incorrect.
    – Ramhound
    May 10, 2021 at 13:47

1 Answer 1

0

So after many hours of tinkering with this issue, effectivley the issue was that the windows installation USB I created didn't work. I downloaded the ISO from microsofts site. I burnt/flashed/mounted it to my usb by using unetbootin, etcher and a variety of manual methods. All of these methods plus different usb sticks plus different usb ports in all variations still gave the same result of me booting into the windows installer, clicking install and then prompted that drivers are missing so I assumed it wasn't the installer that was the issue. Turns out that wasn't the case:

"...Try using rufus, as the old dd based methods don't work any more with never version of win 10." - Electronics Wizardly.

So I created a windows VM. Set up the USB such that the guest OS can use the USB. Then on MS download page there was now the option to use their personal windows install creator so I used that, booted into it and it worked. At this point I'm still in AHCI mode from experimenting. I switch back my SATA mode to RAID and boot into the installer now I was actually able to go through the flow of the installer. When I reached the pick a drive screen, there is a button in the corner to install drivers. It's here where I actually successfully installed the AMD-RAID drivers following their instructions in the manual. I picked my empty SSD to install and it went through without a hitch. When in windows you can then install the RAIDXpert2 management suite where you can tweak further settings.

 

The crux of the problem came down to two things.

 

  1. When switching SATA mode operations in the BIOS, Windows isn't smart enough to detect or deal with it. It just doens't know where to look for the booting process. Installing windows in AHCI mode and switching will lead to this, there are other options out there that I discussed previously such as safemode booting and switching SATA modes or registry edits.

 

  1. If you want to create a Windows installer, you need to have access to a windows machine. It seems like only Rufus and Microsofts own installer seem to be the ones that work. For me at least but I imagine this isn't an uncommon problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .