2

I’m using the webcam passthrough feature in VMware Fusion. However, the frame rate is very low. How do I fix this? Or could this problem perhaps be solved using an external webcam?

Problem:

  • Integrated Webcam running on very low fps (<1)
  • tried with Cheese (like Photo Booth, but for Linux) and VLC Player

Host System:

  • MacOS Big Sur
    • 2.4 GHz
    • 16gb ram
    • 256ssd

VM:

  • Vmware fusion 12.1.1
  • running Ubuntu 18.04
    • 4 Processors
    • 10gb ram
    • 60gb ssd
3
  • 2
    Please clarify your question. Are you asking how to fix this? What do you mean by “with external cameras”? Are you perhaps not using the integrated camera? If yes, does it behave differently on the integrated camera?
    – Daniel B
    May 10, 2021 at 11:54
  • sorry for not being so specific. Yes I am asking how to fix this. I use the integrated webcam of my laptop and, in the future, I plan to use an external connected 3d camera.
    – snice
    May 10, 2021 at 14:15
  • 2
    I rewrote your question to actually ask what you want. Please check whether it’s okay like this.
    – Daniel B
    May 10, 2021 at 14:24

1 Answer 1

1

Certain cameras may not work well with virtual USB camera. Perform these steps to enable pass through of cameras in to virtual machine:

  1. Ensure to shutdown all virtual machines and quit VMware Fusion if its running.

  2. Open Terminal ( /Applications/Utilities/Terminal.app)

  3. Run this command to change the current location.

    cd ~/Library/Preferences/VMware\ Fusion/
    
  4. Open the preferences file using vi or nano editors in terminal

    nano preferences
    
  5. Add this parameter at the end of the file:

    vusbcamera.passthrough = "TRUE"
    
  6. Save and close the preferences file.

  7. Launch VMware Fusion and startup your virtual machine.

  8. Important: Remove all existing camera devices.

  9. (Optional) In some cases, you might want to change the USB compatibility to USB 3.0. It can be changed under "Advanced USB settings"

  10. Click Virtual Machine menu > USB and Bluetooth Setting

  11. Select the Camera you want from the list to connect it to the virtual machine.

This should improve your fps on the webcam. However, the problem is still remains unaddressed from VMWare. Check out the official thread here.

According to this askUbuntu question. Some people have also had luck switching to older versions of VMware.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.