0

I have a random freeze issue since I built my computer and never figured out what was wrong. I worked with it and restarted my computer every time I had the issue. I recently changed my motherboard & replaced my cpu fan with a watercooling, I hoped changing the motherboard would help, but it is now worse. Before, my computer was freezing randomly 1 or 2 times a week, most of the time when I was working on Ubuntu, but I also had the issue on Winwows (I have the two installed on 2 different SSD, I switch at boot : Ubuntu for work and Windows to play games).

Now, I cannot even use Ubuntu, it just freezes almost every time I try to use it. Sometimes I can do some things before, sometimes just starting firefox make it freeze. I didn't had the issue on windows since I changed the motherboard, I do use it less than Ubuntu but still.

Here are some details about the freeze:

  • keyword/mouse not responding, keyword leds (caps lock, num lock) frozen too. Can't open a console with Ctrl+Alt+F3 either.
  • No error led on the motherboard, no error sound either.
  • sometimes the music freezes too (loop of less than a sec, sometimes bigger loop). Sometimes music is shutdown.
  • Screens are frozen too of course.
  • Only solution: hard reset of the computer.

The hardware:

  • CPU: AMD Ryzen 7 3700X
  • Motherboard: MSI MAG X570 TOMAHAWK WIFI, previously (same bug but less often) B450 AORUS PRO
  • CPU FAN: MSI CORELIQUID 240R
  • RAM: Corsair Vengeance LPX Series Low Profile 32 Go (2 x 16 Go) DDR4 3600 MHz CL18
  • GPU: EVGA GeForce RTX 3080 XC3 ULTRA GAMING
  • SSD/HD: Samsung 860 EVO 500GB (Ubuntu), Samsung 860 PRO 256GB (Windows), other for data: WD20EZRX 2To, SanDisk 960GB, Samsung 970 Evo Plus 1TB (Nvme).
  • Power: Corsair AX850 80PLUS Titanium

What I tried:

  • CPU benchmark with hardinfo (all of them): no freeze.
  • Removing 1 RAM and test with the other: freeze with either of them.
  • Removing the Windows SSD: freeze.
  • Wiping out the entier Ubuntu drive and reinstalling it from latest image (USB EFI): freeze, even had a freeze once from the usb itself when installing.
  • Boot ubuntu with options: "noacpi" or "processor.max_cstate=5 rcu_nocbs=0-11": freeze.
  • Reset motherboard settings to default: freeze.

I'm about to go crazy so if anyone has a lead I can work on, I would really appreciate it. My guess would be an issue in the CPU (since I changed the motherboard and the issue persist with either of the 2 ram), but I would like any other opinion on that and a way to be sure it's the source of the issue, because I can't just return it to my seller if it works fine...

Thanks.

2 Answers 2

0

This looks similar to something I'm seeing with a Ryzen 3700X on a Gigabyte B550 Motherboard. I'm using 5.12 and 5.13.x kernels, which has improved the support for the Radeon RX 5500M graphics card... My system usually freezes as you describe, often in a video conference with BigBlueButton - computer appears to be running, but accepts no input (keyboard or mouse) and the camera (USB) stop accepting images and dies. I suspect that part of the problem in my case is a motherboard issue with the USB hardware. The only vaguely relevant kernel messages related to the crash seem to be "usb1-3.1: Failed to query" messages around the time of the crash.

1
  • Thanks for your feedback. I tried keeping a "sudo journalctl -f" running on one screen to see any error message when it freezes. But I don't see anything matching between crashes, it's like there is no error catched (or may be in another log?) when it freezes. You didn't find any solution on your side?
    – Sosthen
    May 13, 2021 at 13:26
0

I have the same problem using the same mainboard / cpu combination (Ryzen 7 3700X on MSI MAG X570 TOMAHAWK WIFI).

The solution that works for me is to increase CPU voltage by 0.025 volts in the BIOS:

  • set "CPU Core Voltage" to "offset mode"
  • set "CPU Offset Voltage" to 0.025V

enter image description here

I have absolutely no freezes any more with this setting. As soon as this setting is removed (e.g. after BIOS update and resetting to default BIOS settings) the freezes are there again.

Hope this may help you.

1
  • Thanks a lot for your help! At first it looked like it was working, I was able to use my Ubuntu a lot more than usual. But then after seeing a few errors reports (some things crashed, Firefox and some libs with untypical errors as searching them on Google gave no result), the computer froze like before. Don't know what's wrong with this hardware and linux, but it's really bad. I don't really see any explanation on why it's working for you, do you have any other setting different than default in your bios? Thanks.
    – Sosthen
    Jul 16, 2021 at 18:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.