I am new to arch and networking. After reading the doc and many posts, I am still unable to solve my problem.

I am running arch on virtualbox. The host machine uses a wireless connection. I installed arch, and followed the installation guide to set up my hostname and hostname resolution. But the network didn't work without install image. So I installed dhcpcd and enabled it. Now I am able to ping and get response. But I am still unable to ping a domain name. And I get no ipv6 routers available message from dhcpcd.

I think this is related to DNS resolution. My /etc/resolv.conf is empty besides some comments. If I manually add nameserver as mentioned here, the problem is solved. But my understanding is that I should not need to manually set the resolv.conf file, it should be handled by hdcpcd.

I think the problem is DNS resolution as detailed here. I started the dhcpcd and systemd-resolved, now I am able to ping a domain name although the dhcpcd client still has the same error msg. nslookup and host cannot connect to server either.

Also, I have not set up clipboard so I only have screenshots. Any hints are helpful! enter image description here

My host is a mbp with wireless connection, here is output of ifconfig

lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
    inet netmask 0xff000000
    inet6 ::1 prefixlen 128
    inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
    nd6 options=201<PERFORMNUD,DAD>
gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280
stf0: flags=0<> mtu 1280
EHC29: flags=0<> mtu 0
EHC26: flags=0<> mtu 0
XHC20: flags=0<> mtu 0
    ether 10:dd:b1:a9:eb:c0
    nd6 options=201<PERFORMNUD,DAD>
    media: autoselect (none)
    status: inactive
    ether 4c:8d:79:e8:8e:d0
    inet6 fe80::1423:696d:a3f1:3d11%en1 prefixlen 64 secured scopeid 0x8
    inet netmask 0xffffff00 broadcast
    nd6 options=201<PERFORMNUD,DAD>
    media: autoselect
    status: active
    ether 0e:8d:79:e8:8e:d0
    media: autoselect
    status: inactive
    ether 52:8c:a3:f0:33:f7
    inet6 fe80::508c:a3ff:fef0:33f7%awdl0 prefixlen 64 scopeid 0xa
    nd6 options=201<PERFORMNUD,DAD>
    media: autoselect
    status: active
    ether d2:00:18:1f:c2:40
    media: autoselect <full-duplex>
    status: inactive
    lladdr 10:dd:b1:ff:fe:81:fc:24
    nd6 options=201<PERFORMNUD,DAD>
    media: autoselect <full-duplex>
    status: inactive
    ether d2:00:18:1f:c2:40
        id 0:0:0:0:0:0 priority 0 hellotime 0 fwddelay 0
        maxage 0 holdcnt 0 proto stp maxaddr 100 timeout 1200
        root id 0:0:0:0:0:0 priority 0 ifcost 0 port 0
        ipfilter disabled flags 0x2
    member: en4 flags=3<LEARNING,DISCOVER>
            ifmaxaddr 0 port 11 priority 0 path cost 0
    nd6 options=201<PERFORMNUD,DAD>
    media: <unknown type>
    status: inactive
utun0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 2000
    inet6 fe80::461a:1df6:901b:70f5%utun0 prefixlen 64 scopeid 0xe
    nd6 options=201<PERFORMNUD,DAD>

This is the network setting of the VM. It's in default settings.

enter image description here

  • I think it would be helpful to get a bit more context here, especially regarding the host OS config and your overall network. Also, it's worth noting that you may technically not necessarily need DHCP to configure IPv6 since that can also be achieved stateless. – jvda May 10 at 19:21
  • Also, did you consider this?. In general I think this question needs a bit more info w.r.t. what you tried so far. – jvda May 10 at 19:22
  • @jvda Thanks! so it seems this is a router connection problem? when I install the system I did not config wireless connection so I assumed the vm is somehow using the host machine's connection somehow. But it seems that is not the case? I need to configure the wireless connection here? – Kabocha Porter May 10 at 19:37
  • Not necessarily, and I can't know for sure without knowing more about your network (e.g. does your network even support IPv6?). But it is a common theme when using virtualbox that the network configuration of virtualbox (not the upstream router) is not configured in bridge mode. Can you post the virtualbox network config and the network config of the host OS? – jvda May 10 at 19:48

Both stateless (e.g. routing advertisements) and stateful (e.g. dhcp-v6) configuration mechanisms will only affect the guest OS if you switch from "Attached to: NAT" to "Bridge" networking.

If you use NAT (as you do now) both networks (the one used by host and by guest) are isolated. Only outbound traffic from the VM is NATed, therefore DHCP offers from your router are not reaching the VM.

Also, the IPv6 configuration of the interfaces on the host OS only show link-local addresses which may indicate that your network does not provide internet-access using IPv6.

To get around the DNS issue, you can either set the VM network to bridge mode as shown above, manually configure a reachable DNS server in resolv.conf (e.g. specifying your router or a public DNS) or enable DNS proxying.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.