9

I'm trying to use an old parallel-port based printer with a USB-to-parallel port adapter on Windows 7. When I plug it into the USB port on the computer it's listed as an unrecognized device. I know that these cables typically use the "USB Printing Support" driver with makes USB ports show up as printer ports in the printer dialog. Is there a way to manually add USB Printing Support to Windows 7, since it isn't being added automatically?

  • You do need a driver to get it out of the unrecognized device list. You may have to go to the manufacturers website and download it. Some USB to parallel devices are not compatible with all hardware you may have to buy a brand from a different company. – cybernard Jun 10 '17 at 15:08
  • Once you get the USB-to-Parallel adapter drivers installed, try using an HP LaserJet 4 driver. Those seem compatible with most any printer. Try PCL, and if that doesn't work, try PostScript. – Brad May 26 '18 at 16:40
1

You can add the printer manually via:

  1. Control Panel -> Devices and Printers -> Add a Printer -> Add a Local Printer
  2. In Choose a Printer Port, select Use an existing port
  3. In the drop down menu, select the USB001 or USB002 etc. (Virtual Printer Port for USB)
  4. Select Next
  5. In the Manufacturers section, select the printer's manufacturer
  6. In the Printers section, look for your printer model and select it.

If the printer model is not available, you will need to manually supply the driver.

EDIT

The USB-to-parallel port adapter should have come with a driver. If the driver is not installed, then the device will indeed show up as unrecognized. If you don't have such a driver, please let me know the manufacturer and model of the adapter and I'll try to find one. I'll also need to know whether you're running Windows 32-bits or 64-bits.

  • 1
    The problem is that I don't have USB001/USB002/etc ports as options. That's why I need to install USB Printing Support. – Kevin Dente Jul 17 '10 at 23:44
  • @Kevin Dente: See my edit. – harrymc Jul 18 '10 at 6:45

Not the answer you're looking for? Browse other questions tagged or ask your own question.