I used the migration assistant to copy my files directly from my old Mac to a new one.

My new Mac won't "link" Time Machine backup on my Airport disk.

I can browse the old Time Machine backup, however.

I did find the related article with this specific comment: http://www.macosxhints.com/comment.php?mode=display&format=threaded&order=ASC&pid=97623

Unfortunately, my Mac still won't associate with the old Time Machine backup.

Any advice?


3 Answers 3


I think you shouldn't try to do this.

I used the migration assistant to copy my files

So, you've copied your documents and some more (but not the whole backup), after you installed Mac OS X (or, onto a system that had OS X pre-installed)? If so, then the old backup is simply not a good representation of your current Mac.

If you could somehow enforce a deep traversal (for this to happen, fseventsd on your Mac must be fooled into "events log in /Volumes/.. out of sync with volume. destroying old logs.", followed by Time Machine's "Event store UUIDs don’t match [..] Node requires deep traversal"), then maybe it will become a reliable full backup after all. And then this new backup, or any newer backup, can be used for a full system restore (but not using backups that were created before the deep traversal, as I think those certainly do not match your current Mac).

If you really want to go that way, then we need more information about the problems you're currently facing. Anything in the log files (Console) for example?

I can browse the old Time Machine backup, however.

Using Finder, or using Time Machine? If, at any time, you want to restore files from any Time Machine Backup, then simply hold down Option while launching Time Machine (or while clicking the icon). This will change "Enter Time Machine" into "Browse Other Time Machine Disks".

  • This is using time machine. There are no logs, it simply tries to make a new time machine backup. I backed up to time machine right before I migrated. So both macs have "identical" content. The reason I restored from the Mac (and not the time machine backup) is because it was faster and I don't backup my entire laptop to time machine, but after this may rethink that. Jul 15, 2009 at 17:04
  • Not all Macs are equal, I'd say. I don't know if it would get you into trouble, but I don't think both Macs will have "identical" content. However, if it wasn't a full backup to start with, then indeed it might not matter at all. (There are always logs; look for backupd in Console.)
    – Arjan
    Jul 15, 2009 at 19:31

This is not my answer, this is a copy/paste of the article linked by the original poster, for easier reference:

From: http://www.macosxhints.com/comment.php?mode=display&format=threaded&order=ASC&pid=97623

I too have had to restore a Time Capsule-based TM backup, and it turns out that this procedure does work. The order of the commands is a little bit modified, but this should take care of things for you. In the proceeding code, let's assume that that "Time Capsule" is the internal disk of your Time Capsule, and "Backup of MyMac" is the name of the sparsebundle disk image volume that mounts when you normally back up to your Time Capsule. First off, double-click your old (correct) sparsebundle disk (MyMac_00f9e8d7c6b56.sparsebundle) image and mount that volume on your Desktop. Also, to reiterate, old MAC = 00:f9:e8:d7:c6:b5, new MAC = 00:1a:2b:3c:4f:56, as they are above.

$ sudo fsaclctl -p /Volumes/Backup\ of\ MyMac -d
$ sudo xattr -w com.apple.backupd.BackupMachineAddress 00:1a:2b:3c:4f:56 /Volumes/Backup\ of\ MyMac/Backups.backupdb/MyMac
$ sudo fsaclctl -p /Volumes/Backup\ of\ MyMac -e
$ cd /Volumes/Time\ Capsule
$ sudo mv .00f9e8d7c6b56 .001a2b3c4f56
$ sudo mv MyMac_00f9e8d7c6b56.sparsebundle MyMac_ .001a2b3c4f56.sparsebundle

What we've done here is we've disabled and re-enabled ACLs within the sparsebundle volume (where Backups.db actually is) and used xattr to change the MAC address in the manner shown in the original hint. Next we went to the Time Capsule's volume and changed the MAC address file and the name of our backup to both reflect our new MAC address. I'm fairly certain this should work for Time Capsule-based TM backups...it has worked for me, so best of luck.

  • I just tried what you put above, but unfortunately it failed on the first line with the message: "sudo: fsaclctl: command not found" :(
    – Joe
    Sep 4, 2011 at 13:43

Installing my dev copy of 10.6 over my Leopard install fixed this issue. I am not sure if 10.6 is "smarter" about Airport Drives/Time Machine OR if there were some preferences that a reinstall fixed.

I can say that 10.6 "appears smarter" because it uses the Time Macing icon to indicate my Time Machine drive. Even when Time machine was working properly on my previous MacBook, it used a generic white drive icon.

So if anybody else runs into this issue either an upgrade or reinstall should help.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .