11

I have a Wifi AP without internet access that allows me to access some devices at home. I want my Windows 10 to keep connected to that wifi network, but once Windows detects there is no internet, it insists on disconnecting from it.

I disabled "Connect Automatically" from all networks, but once Windows detects there is no internet it insists on disconnecting from it.

How can I keep Windows 10 connected to a network without internet access?


Edit: Looking at event viewer, I see this event every time it disconnects:

WLAN AutoConfig detected limited connectivity, attempting automatic recovery.

Recovery Type: 4
Error Code: 0x0
Trigger Reason: 3
IP Family: 0

Tried netsh wlan set autoconfig disable but this turns off the wifi network list.

9
  • 1
    See if your Wireless Router is broadcasting when no Internet. If my Internet goes out, the connection to the router stays, but I get the Globe icon = no Internet.
    – John
    May 19, 2021 at 0:06
  • Are you moving the Windows 10 device out of range of the Wifi itself (e.g. taking it outside your home)? May 19, 2021 at 0:22
  • 1
    That's not normal behavior - check the WiFi adapter's Properties > Configure > Advanced tab settings, as well as Settings > Network > WiFi
    – JW0914
    May 19, 2021 at 2:41
  • 1
    I'm not moving. The wifi is close. If I open the route to the internet on that router, windows keeps connected so I don't think it has anything to do with the router. I just remove the default route and windows disconnects after 30 seconds or so. I added the event on the event viewer that appears here.
    – Natan
    May 19, 2021 at 12:11
  • 2
    I too am looking for a solution to this. Occasionally there comes a prompt that asks "do you still want to stay connected to this network even though there's no internet?" which seems to be the solution, but I haven't seen it since I reinstalled, and I don't know how to trigger it manually... Apr 28 at 0:06

2 Answers 2

4

My favorite way: just add a registry value to the following key: Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\NetworkConnectivityStatusIndicator:

  • Name: NoActiveProbe
  • Type: DWORD (32bit)
  • Value: 1

Alternatively, expanding on Batuhan's last idea, this is how I implemented it:

  • I remapped both URLs to 127.0.0.1 via the hosts file, by adding those lines:

    127.0.0.1 www.msftconnecttest.com

    127.0.0.1 www.msftncsi.com

  • And installed a local webserver (XAMPP). There you just need to add a ncsi.txt to the (in my case C:\xampp\htdocs)

I had to wait a minute or so for the icon to change, but then it worked like a charm...

3
+50

There may be some possible workarounds for this. You may disable the internet test and captive portal detection or make Windows believe there is a İnternet connection.

After connecting to a network Windows tries to resolve www.msftconnecttest.com address. If the query returns a response, it tries to fetch the contents of http://www.msftncsi.com/ncsi.txt file. If this action fails Windows determines that there is no internet connectivity, or the ncsi.txt request returns a different content then it concludes that there may be a captive portal.

You may disable this "probing" with a group policy, see the following page for further info: https://admx.help/?Category=Windows_10_2016&Policy=Microsoft.Policies.InternetCommunicationManagement::NoActiveProbe

It may be also possible to return the localhost IP for said domain name using hosts file and serve the same txt file but its not that trivial to do so and may not work as intended.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.