I've tried every single solution out there and nothing works. Here's the deal; I had WIndows XP. I backed up some stuff to an a drive. I installed Windows 7. Now I'm trying to access the files I backed up and I get access denied errors.

Things I've done that haven't worked:

  • Changed ownership to my main user account
  • Ran cacls over the offending folder
  • Ran explorer as admin to access files
  • Gave full (recursive) permissions to just about every network entity north of the equator

I did see the "old" NTFS account S1-34534-3453(and so forth) and replaced myself as owner/admin/omnipotent being.

Nothing has worked thus far. Any help is appreciated.

As an aside, could a dual boot with linux access the files?

  • While I don't have a direct answer to your question, if you do have Linux installed, by all means try it from there. If not, you could also try it from a live CD of any distribution, such as Ubuntu. – Emory Bell Jul 18 '10 at 16:08
  • I did have Ubuntu 10 live disc laying around but it failed to complete loading. I'll have to check out another distro. EDIT: Getting Linux Mint. Looks cool :) – Nick Swarr Jul 18 '10 at 16:16

I've definitely run into this numerous times doing data recovery for friends. The solution that works every time is amusing: borrow a friend's Mac. They just ignore the file permissions :-) If you want to copy it back to your PC, just copy it to another drive.

| improve this answer | |
  • 3
    A Linux Live CD will also do the job nicely. – Andrew Moore Jul 18 '10 at 17:19
  • +1 for Live CD. That way, you don't have to install anything and risk messing up the data on the drive even more. – nhinkle Jul 18 '10 at 19:56
  • So I did get the Linux Mint live CD running and it gets access denied errors on the files as well. I've never seen that before...is there something special I need to do to bypass the NTFS security? – Nick Swarr Jul 18 '10 at 20:58

Unfortunately, I finally figured out what the issue was. I hadn't been paying attention to the color of the text for the files and directories. They are green indicating that the files are encrypted. It seems that XP pro encrypts files by default? Not altogether sure but what I'm reading is that those files are gone...no way to retrieve them. So, this wasn't a Win7 issue at all.

| improve this answer | |

Have you tried using the Windows tool "Takeown" to take ownership of the files? See here.

| improve this answer | |
  • Thanks for the tip. I tried it but it still doesn't work. Still no access. – Nick Swarr Jul 20 '10 at 2:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.