1

enter image description here

I have moved to an apartment where the network port is too far from my desktop so it's not possible to have wired connection. So, I setup a network using an extender. I initially setup A. I had an old router (Tilgin) lying around so I used it. But the network speed on Desktop/NAS was kinda slow.

Then I replaced the Tilgin router with a switch as shown in B. Now internet on the Desktop/NAS is weird. It's on and off a lot. It works a bit when I am browsing and then it goes off completely. When it works, the speed is the same as it used to be. But the connection is so intermittent and choppy. Every few secs, it's like there is no internet at all.

Internet on the smartphone/laptop from the first router (tp-link) and extender works fine in both cases A and B, so I assume it's something to do with the switch.

Any ideas on what might be wrong? Perhaps something conflicting? I am not even sure how to diagnose this and what metrics to look for. The desktop is running Windows.

EDIT: Long story short, the wifi extender can only handle one wired device.

4
  • 2
    I really suspect it has something to do with the extender. Wi-Fi does not normally support multiple devices (multiple MAC addresses, to be specific) on a single connection, and "Wi-Fi extenders" have to do very ugly things to make that happen. Can you try reconnecting e.g. the NAS or the desktop directly to the main router and check if the remaining one device continues having the same problem or not?
    – user1686
    May 19 at 18:35
  • When connected to the main router, it works fine. One thing I am curious about is, in setup A where I used the Tilgin router, I wonder if it was acting as a router or an access point. If it actually assigned IP addresses. I didn't think about it then. Just plugged it in and it worked. In setup B, I guess the switch doesn't do anything fancy. It's unmanaged. So the main router has to do all IP assignment and I am not sure how the extender is affected.
    – rmf
    May 19 at 19:36
  • 1
    If the router was working as a router, it re-sent all packets using only its own MAC address. A switch preserves the original ones. That's the difference.
    – user1686
    May 19 at 20:06
  • You were quite right about your initial suspicion on the extender :)
    – rmf
    May 19 at 20:57
1

What you are attempting to do will not work. The RE305 is an extender, not a bridge. As soon as more than one MAC address appears on its wired connection, it gives up, since it would have no way to know which device to route incoming packets to.

This a limitation of all client station devices that are not routers. You can't bridge a WiFi client to an Ethernet segment. This is the problem that WDS connections solve. (If you could, WDS wouldn't be needed. You could just connect to the AP as a regular client and bridge.)

7
  • Aha! I think you might be on to something. I was actually looking into the extender settings. It has 2 operation modes: extender (wifi to wifi) and access point (cable to wifi). While what I probably need is access point (wifi to cable) which is not an option although it has a network port. So if I understand you, the extender can have multiple wifi clients but only one wired client?
    – rmf
    May 19 at 20:25
  • @rmf Correct. It cannot handle more than one MAC address on the wired port. You cannot "build out" a wired port from a client WiFi connection. May 19 at 20:30
  • It does seem to explain the behaviour. In setup A where it worked, the tilgin router was probably acting as a router. In setup B, the extender picks either the desktop or nas and keeps switching one or other. So the switch doesn't really have any role in this issue. But damn that's a shame! Is this true for all extenders or just this model? Is it not possible at all to extend wifi into multiple wired connections? Is it a good idea to go back to setup A although it's slow?
    – rmf
    May 19 at 20:39
  • 1
    Some extenders can handle this – but the "ARP NAT" they perform causes a lot of problems and I would never recommend using it. Really, don't. (Dedicated point-to-point Wi-Fi bridges also have a special 4addr mode which handles multiple MACs properly, but the AP has to support it too.)
    – user1686
    May 19 at 20:41
  • @rmf I wonder why it was slow. There's no particular reason that it should have been. Something may just have been configured incorrectly. Just remember, you will have two LANs at that point, which may make your NAS somewhat useless since it's not on your other LAN. May 19 at 20:44
1

See the User Guide and especially Chapter 6 : Monitoring. I believe that this manual relates to your switch.

You may login to the switch at http://192.168.0.1 (ensure that there is no IP conflict with another device on the network). The first stop is at Monitoring > Port Statistics. You will find there more information that may tell how the problem manifests itself, by bad packets or other problem.

In Monitoring > Cable Test you will be able to diagnose the connection status of the cable connected to the switch. This may also help to analyze where the problem is.

If no hint to the problem is found, you might consider trying another switch.

4
  • Hmm.. That logs me into my main router. And I wasn't able to find "Monitoring" exactly. But on the "home" page, I could see all the connected devices and everything is shown as wireless devices including my desktop. And they all have distinct IP adresses. 192.168.0.X. I am looking further into some of your other suggestions.
    – rmf
    May 19 at 19:43
  • I tried pinging the desktop from the main router. It works 1.925 ms. But, not sure if that means anything much.
    – rmf
    May 19 at 19:51
  • 1
    If connected directly via cable, it should be less-than 1ms. If the switch is in the middle, this might still be slow, but I don't have experience here. Note: It might be that the manual doesn't relate to your sub-model, if your switch is not managed.
    – harrymc
    May 19 at 19:57
  • Ah yes. I believe my switch is unmanaged. I was a bit lost about logging into my switch.
    – rmf
    May 19 at 19:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.