0

My laptop is persisting in trying to boot from a recovery volume by labelling it C:, and won't boot to Windows in any mode. Stop code is Inaccessible Boot Device. On going into advanced recovery then command prompt I can see that a recovery volume is mounted as C: rather than the larger and normal system partition which holds Windows.

I've tried a number of things, including:

  1. Reassigned label to correct partition in diskpart per here.
  2. Turned off Automount and scrubbed Automount entries per the same link
  3. Modifying (somewhat randomly) BIOS boot options re UEFI mode legacy etc.

The machine still wants to boot to the wrong volume.

If I look at HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices with reg query (I cannot get to Windows to run Regedit) I can see that the mounts are mixed up. Because I cannot get to Windows to run RegEdit per here. I'm uncertain what to do next.

Note that I am concerned about data loss. The drive is BitLocker encrypted. I'm cautious not to delete the reg key from cmd prompt in-case I can't get it back. I have little confidence in the recovery partition being up to date, and happy to disable it if I can re-enable.

Background:

This happened when trying to fix my machine requesting Bitlocker recovery key on each reboot at the same time as doing a driver update. (silly to do the two things at once I know) I have followed instructions to disable Bitlocker from Reddit. Only after re-enabling did I even get prompted for my recovery key, but at least I felt like I was getting somewhere since I can see the old C drive, but after remapping via DISKPART it comes back again per above.

7
  • By convention, C: is assigned during the boot process, to whichever drive is booting. Attempting to change the letter from outside that process is pretty pointless. You need to determine why it thinks it should boot from there rather than what letter it assigns the drive.
    – Tetsujin
    Commented May 23, 2021 at 10:15
  • Yeah, fix your BCD, I guess.
    – Tom Yan
    Commented May 23, 2021 at 10:23
  • Thanks @Tetsujin. I believe it is trying to boot from Recovery either because it thinks it needs to in recovery mode, or because the Windows drive (which was C:, but is now D:) was temporarily unavailable as I messed with the Bitlocker. How would I determine/confirm "why" it is reassigning the volume previously unassigned recovery partition and how would that help me/what are the next steps you recommend?
    – Topdown
    Commented May 23, 2021 at 11:26
  • @TomYan do you mean fix BCD per here? if so, can this be run from same command line and will it leave my bitlocker contents intact and uncorrupted?
    – Topdown
    Commented May 23, 2021 at 11:28
  • Fixing the BCD should not cause any change to your "C:" (unless it's in the same partition), but I'm not familiar with booting a bitlocker-locked drive so I don't know if you need special procedure. bcdboot is one of the ways to fix it, but I suggest you read the documentation of the program itself on Microsoft's website instead of some random tutorial. bcdedit is another program you might want to take a look into.
    – Tom Yan
    Commented May 23, 2021 at 11:55

1 Answer 1

0

Try this :


Boot recovery > advanced recovery > cmd

Diskpart

list volumes {check the letter of the drive to boot}

exit {to exit the dispart}

Bcdboot D:\Windows {replace D with the letter of the drive to boot you just checked}

4
  • Thanks. Do you know if there is any risk to the Bitlocker drive (which is the boot drive) using Bcdboot?
    – Topdown
    Commented May 23, 2021 at 13:09
  • @Topdown no there will be no issues ; docs.microsoft.com/en-us/windows/security/….
    – Madhubala
    Commented May 23, 2021 at 13:33
  • Tried this, and get unaccessible Boot Device Blue screen just as before. After booting next time I get prompted for Bitlocker key which I enter. A second after this I get a screen saying: "Recovery"... "After multiple tries the operating system on your PC failed to start so it needs to be repaired. Error code 0xc00000001. You'll need to use recovery tools. If you don't have any installation media (like a disk or USB) contact your PC administrator or PC/Device manufacturer)." Prior to running BCDBOOT it would at least get me to cmd prompt. Any ideas now?I am unsure I have a recovery disk
    – Topdown
    Commented May 24, 2021 at 14:52
  • @Topdown it seems the win drive is corrupted; if data on drive is imp then it's better not to touch the drive and do fresh installation somewhere on other partition > copy the imp files > then try repairing this
    – Madhubala
    Commented May 26, 2021 at 13:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .