13

Home Network Setup: Cable Modem connects to TP-Link Archer A9. Archer A9 broadcasts wifi and has devices connected via Ethernet. Wired devices includes three switches which then have various devices connected to them: computers, TVs, gaming consoles, etc.

Problem: All was working fine until yesterday when the Internet throughout entire house went out. Did all of the normal devices reboots; nothing worked. Tested modem by connecting directly to it via Ethernet; Internet worked fine. Connected Archer A9 to modem and verified Wifi devices Internet worked. Plugged one switch in at a time. Switches #1 and #2 Internet worked fine. As soon as Switch #3 was connected, the problem happened again where the entire house (both wifi and wired) all lost Internet. Assuming it was a faulty switch, I swapped it out for an old router that has been configured to work like a switch (DHCP disabled) and it happened again, all lost Internet. Assumption is that the switch #3 was not faulty and it might be one of the devices connected to it.

Question: What is going on? Could a device connected to switch #3 cause this type of disruption that causes all devices to lose Internet connectivity? Any way to resolve this problem?

4
  • When the Internet goes down, can the devices connect to each other? Can they ping the router? I also assume that the router has a built-in admin webpage. Can you access that?
    – Vilx-
    May 26 at 8:55
  • Are you sure you need all those switches? it is not doing your throughput any favors I think and you are creating points of failure. May 26 at 9:00
  • Have you heard of netcut? Jun 5 at 7:54
  • Thank you everyone for your input. To answer some specific questions, no, the devices received 169 IPs so they were not able to see each other. Likewise, couldn't access the router admin. Using ideas from multiple answers, I kept troubleshooting. I took a shotgun approach and eventually turned off every device on the network, not just the network devices, factory reset router, then powered on devices one at a time. My guess is there was some type of conflict and powering down every device resolved it. Jun 6 at 6:07
20

It may be possible that some device has assumed a wrong IP address, so that you might have two devices with the same IP. This might cause problems, especially if that IP address belongs to a switch or some gateway.

You could disconnect all the devices on switch #3, to see if the problem still arrives.

If the problem has disappeared, reconnect them one-by-one to find the malfunctioning device.

5
  • were that the case the problem would only affect the devices sharing the same IP.
    – davidgo
    May 24 at 21:29
  • 7
    @davidgo unless the device sharing that IP is the router... A bit farfetched in normal use, but misconfiguration can make it happen
    – jcaron
    May 24 at 22:48
  • @jcaron Good point.
    – davidgo
    May 24 at 23:01
  • A router, one of those problematic devices that can masquerade under a cloned MAC address ? (Just thowing it out there...). DHCP will be confused.
    – mckenzm
    May 26 at 5:18
  • And the A9 supports a VLAN for VPN too, so it may be worth drawing a picture. It is very common for these to be nested behind the ISP's router's LAN too (double NAT) but this is not the case here.
    – mckenzm
    May 26 at 5:21
13

This sounds very much like a routing loop, ie switch 3 has more then 1 path to the router - maybe a direct connection and a connection vua another switch?

You can diagnose this problem by tracing the connections from switch3 back to the other end. A lazier way, which might not work as well would be to discomnect everything from switch 3 and gradually re-add devices until it crashes.

1
  • 1
    Just to be pedantic, this isn't a routing loop, as the loop is between switches and doesn't traverse a router. But otherwise, this seems spot on as the likely culprit, especially if the entire network immediately fails. The spanning tree protocol is suppose to fix this, but there's a lot of dumb switches that don't know STP. Also, a device with incorrectly configured STP could cause this.
    – user10489
    Jun 5 at 6:49
3

It's difficult to diagnose without more details, but beyond what is described in the other answers:

  • Did you make any changes to your network setup? Added or removed devices, changed configuration, performed an upgrade?

  • Do the devices still reach each other? I.e. is it just access to the Internet which stops working, or all network communication? Of course you may need to performs tests between many different pairs of devices to isolate the issue.

  • Some problems can show up quite late after a change. For instance, if there's an issue with DHCP, you may not notice it until the current DHCP leases expire (which can be quite long).

  • In addition to having multiple devices configured with the same IP, another potential issue is multiple devices acting as DHCP servers.

  • It's not unheard of to have multiple devices with the same MAC address! Shouldn't happen, but...

  • Loops in the network are normally detected and stopped by the spanning-tree protocol (STP / RSTP), but depending on the exact setup...

  • You may have a faulty or infected device that is flooding the network with traffic. If that traffic is itself amplified by other devices it can DoS your network.

As others have written, you should continue your diagnosis until you find a single device which causes the disruption. Depending on the type of device, there can be various ways to find the exact cause and then fix the problem.

2

Last time I encountered an issue like this, it was due to the addition of an access point configured for 'routing/DHCP' to the network. Having 2 routers set for DHCP took everything offline. This would be an extension of the 'IP conflict" issue proposed in a previous answer. Connecting to the router and seeing what errors are being tossed back is the best bet IMO to get an accurate diagnosis.

Once on the network, you can use This documentation to get into the router.

1
  • 1
    Or, more cryptically, what happened to us long ago. Some machines worked fine, some refused to work unless given a static IP. Occasionally a machine would switch from the former to the latter. Turns out someone had enabled DHCP on a NT box. So long as a machine had a proper lease from the real router everything worked. If for any reason it lost the lease it might find the bogus one instead. Jun 9 at 18:24
2

A loop on switch 3 could cause a broadcast storm which would take down the entire local segment. A non-lacp/non-trunk double-link between switch 3 and either switch 2 or switch 1 (assuming not using STP) would create a similar loop and broadcast storm. You wouldn't be able to ping anything.

I've seen this happen both because of a port-to-port patch and because of a split-brain lacp link.

A DHCP server connected to switch 3 could provide addresses in a non-usable range, but this would not produce an immediate outage.

Trace all cables on switch 3 and/or disconnect all cables to it and re-connect them one-by-one, then trace at the point failure occurs.

1

It is possible that some device connected to switch #3 is a problem.

Simply to disconnect all devices from switch #3 and then reconnect them one by one and see what happens.

If any of those devices causes connection problem, check configuration. Could be DHCP or gateway configuration problem etc. There's multiple possibilities.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.