1

I just did a fresh install of Debian (Debian 10 - Buster). When I boot it up, the resolution is wrong and on settings -> display I've got only one option of resolution. I installed the corresponding drivers using this tutorial: https://wiki.debian.org/AtiHowTo

After rebooting quite a few times, the problem persisted. Then I checked the drivers with find /sys | grep drivers.*08:00.0 and find /dev -group video and both give me an empty output. From there I concluded that the drivers are installed but not working, or activated at least. But after that I'm out of ideas. Thanks in advance.

Here are the characteristics of the CPU and GPU:

Architecture:        x86_64
CPU op-mode(s):      32-bit, 64-bit
Byte Order:          Little Endian
Address sizes:       43 bits physical, 48 bits virtual
CPU(s):              8
On-line CPU(s) list: 0-7
Thread(s) per core:  2
Core(s) per socket:  4
Socket(s):           1
NUMA node(s):        1
Vendor ID:           AuthenticAMD
CPU family:          23
Model:               24
Model name:          AMD Ryzen 5 3400G with Radeon Vega Graphics
Stepping:            1
CPU MHz:             1532.004
CPU max MHz:         3700.0000
CPU min MHz:         1400.0000
BogoMIPS:            7385.90
Virtualization:      AMD-V
L1d cache:           32K
L1i cache:           64K
L2 cache:            512K
L3 cache:            4096K
2
  • First of all disable Secure Boot in UEFI. May 24, 2021 at 16:02
  • It was disabled by default.
    – Morganuz
    May 24, 2021 at 18:11

1 Answer 1

0

For me this line into /etc/default/grub helped:

GRUB_CMDLINE_LINUX="amdgpu.dc=0 video=2560x1440"

You may have a different resolution or a bit different card, so check, please.

After I perform (contratry to the guide mentioned) update-grub. It needs to run without issues to be effective.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.