I just created a HomeGroup on another Win7 machine at home and am trying to connect my main machine to it. Unfortunately, I'm getting an error that I think relates to my usage of Comodo Firewall.

When I go to Control Panel --> Network and Internet --> HomeGroup, Windows recognizes that I've created a HomeGroup from another machine on my network. Next, I click Join now and enter the custom password that I set. After entering the password, I click Next, only to be greeted with the following error message:

Your network conenction must have IPv6 enabled to create or join a homegroup. To enable IPv6, start the HomeGroup troubleshooter.

The troubleshooter directed me to my network adapter properties window, where I saw that IPv6 is, in fact, enabled. I've also verified that my network is set up as a Home network and have disabled the adapter that VirtualBox uses.

This leads me to believe that Comodo Firewall, which I've been using on this machine without any trouble for months now, is blocking HomeGroup.

After Googling for a bit, I've noticed that a few people have had issues with Comodo and HomeGroup, but I haven't found much that mentions IPv6.

Solutions I've tried

I will update this list as solutions are suggested.

Opening ports 3587 and 3540:

I found the following solution online:

Whenever I tried setting up the Windows 7 HomeGroup, I kept getting an error message about the password not being correct though it was correctly typed in. COMODO Internet Security was blocking it so this is how I fixed it...

1) Open CIS. 2) Click on FIREWALL at the top. 3) Click on MY PORT SETS. 4) Click ADD > A NEW PORT SET. Call it HomeGroup. Click APPLY. 5) Now find HomeGroup on the list and underneath it, it will say (add ports here). Click on that then click on ADD > A NEW PORT. 6) CIS seems to use both TCP/UDP at the same time so there is no selection for this in CIS. Dot the circle in front of ADD A SINGLE PORT and add port 3587. Click APPLY. 7) Repeat the above and add port 3540. 8) Now go through the HomeGroup setup wizard and everything should work.

In case you use these directions for a different software firewall program, 3587 is TCP and 3540 is UDP.

Also be sure your Network is set to HOME in Network and Sharing Center.

Unfortunately that didn't resolve my problem.

Enabling IPv6 in registry:

I just found this post:

hkey-local machine\system\currentcontrolset\services\tcpip6\parameters Then you have to set the DisabledComponents Dword to 0

A few minutes ago, I had read something very similar on another page:

Note that sometimes the registry setting does not get updated even though you enable IPv6 via the GUI interface. So you can check the setting in the registry by going to the following key:


In the right pane, right-click on DisabledComponents and select Modify. Make sure the value is set to 0. If it’s set to anything else like FF, IPv6 was turned off.

Sure enough, DisabledComponents was set to FF. I changed it to 0, saved my changes, and tried to join the HomeGroup again - didn't fix the problem.

Thanks in advance!

  • Have you tried to disable Comodo firewall entirely just to verify if it is the cause of the problem? – Andy Jul 19 '10 at 8:47
  • @Andy I'm about to set it to not block anything and see what happens. – Maxim Zaslavsky Jul 19 '10 at 8:50
  • @Andy hmm, i set it to disabled and i'm still getting the ipv6 error. weird. – Maxim Zaslavsky Jul 19 '10 at 8:53
  • Just found another post (sevenforums.com/network-sharing/…) that refers to the registry fix but says that you have to reboot for the changes to take effect. I'm going to sleep now and will shut off my computer - in the morning, I'll update this question! :) – Maxim Zaslavsky Jul 19 '10 at 8:56


Turned out that Comodo Firewall wasn't related to the problem at all. I disabled Comodo and tried to connect to the HomeGroup, and it still gave me the same error.

After some more Googling, I found another post about changing DisabledComponents in the registry to turn IPv6 on. I had already done the change, but the post told me that I had to reboot to see the results.

This morning, after the reboot, I was able to connect to the HomeGroup! Looks like a small bug with enabling IPv6 through the network adapter properties window.

| improve this answer | |

The other answer didn't work for me, but I found this:

  1. Right click on the network icon in the taskbar
  2. Open Network and Sharing Center
  3. Select "Change adapter settings"
  4. Right click on your current working internet adapter and click "Properties".
  5. Scroll through the list with check marks and check the option saying "Internet Protocol Version 6 (TCP/IPv6)"
  6. Click "OK"
  7. Now try to create a homegroup
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.