Experimentally, I removed google from the list of possible search engines in the search bar on firefox. Now I can't find it again--apparently so few people need to actually add google that it's pretty much impossible... How do I get google back in the search bar?


Ok, found it. Click on the dropdown to choose the engine, click on "Manage Search Engines...", and click "restore defaults".

| improve this answer | |
  • As of april 2014 Google Chrome doesn't have that option anymore... – emzero Apr 5 '13 at 1:23

Had the same problem, Google disappeared entirely with no way to restore it. The "Manage search engines did not work.

Citing the wonderful answer of Anurag from post How to restore the default Google search engine in Chrome?

Go to

Settings > Search Engine > Manage search engines > Add (button)

Fill in:

**Name:** Google
**Keyword:** google.com

And paste below code in the URL box:


Hope this works for you as well as it did for me!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.