1

I have a 2.4 GHz WT3020 router with OpenWRT supplying WiFi for all my devices at home (4 in total). All of them get great signal and low ping, except for one laptop (Dell Precision 7540, running Windows 10, like all the others) that suddenly started experiencing extremely unstable connection through this WiFi - running ping on CMD jumps from ~30ms to ~3000ms with anything in between in a single 4 ping attempt. Some packets get timed out. It used to be fine a few weeks ago, but now it's getting worse and worse.

I tried switching channels in OpenWRT config - no change. WMM is disabled. Of course, I tried re-installing network card drivers on that Dell, reset everything in Network Connections - didn't help either. That laptop is just 1 meter away from the router, there are no pipes or anything in between - clear line of sight.

I just tried ping again to google.com just now - first attempt, I got 12ms, 38ms, 162ms, 200ms. Then tried it again - got 494ms, request timed out, request timed out, 2833ms. In the meantime, all other computers and phones had a perfect signal.

I don't know what to make of it, especially because I haven't made any hardware or software changes in that laptop, nor in my network config, since the issues started. Any ideas?

EDIT: I just found out that pinging the router itself (192.168.1.1), has the same high ping and timed out requests. Why could this be?

EDIT: Issue solved. Turns out, Onedrive went crazy, and saturated the entire network capacity for that laptop. Turning it off fixed the connection, and restored ping to <10ms. Thanks to everyone who came up with suggestions!

11
  • 1
    Why is WMM disabled? WMM is required for 802.11n and 802.11ac. By disabling it, you make it impossible to use link speeds over 54 Mbps. That causes the device to consume more bandwidth than it should and slows down all devices. Please make sure WMM is enabled on all devices and the router or you will suffer poor performance. See here. Jun 7 '21 at 11:20
  • Does you see the same discrepancy in perfomance when the computers in question are connected to other wifi networks using the same version of 802.11? Jun 7 '21 at 11:23
  • @DavidSchwartz, I have to keep WMM disabled, because another laptop, Lenovo 330s, has a Qualcomm Atheros QCA9377 card, which has a bug that causes extremely slow WiFi if WMM is enabled in the router. There is no other workaround as far as I know. If I enable WMM, I won't be able to use WiFi on that laptop. Jun 7 '21 at 11:27
  • @JeffZeitlin Nope. It seems to work fine with other WiFi's. Jun 7 '21 at 11:28
  • 1
    @JustinasRubinovas The WiFi card on the Lenovo really should be replaced, as WMM is vital to throughput (card is in the upper right-hand corner @ 1:11 - ACM cards cost ~$35)
    – JW0914
    Jun 7 '21 at 13:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.