4

How to change SMTP password in Thunderbird?

Password to my SMTP changed recently, and I can't change it to Thunderbird due some bug.

Changing should work like this:

  1. User send email
  2. Thunderbird gets authentication error: Login to server my.smtp.server failed
  3. Thunderbird prompts for new password: Enter New Password

The problem is that when I click Enter New Password, no password prompt appears, Thunderbird just tries to reconnect and that, of course, fails.

Is this a known bug? Is it fixed in later releases? Can I fix the problem manually by editing Thunderbird setting files?

Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.10) Gecko/20100528 Thunderbird/3.0.5

I am using Ubuntu 10.4 and the Thunderbird that comes with it.

3 Answers 3

4

You have to clear the memorized password in Edit - Preferences - Security - Passwords tab and Memorized passwords button and select the account/password to remove. Next time it will ask for a new password.

Maybe the menu names are a little different because I see them translated on my version.

8
  • 1
    Thanks, that work. I still think that there is some bug in TB. Previously when password has changed on the SMTP server, the software has automatically prompted for the new password. Jul 20, 2010 at 12:44
  • Yes, I agree with you this is the way it should work!
    – laurent
    Jul 20, 2010 at 20:26
  • Unfortunately, this doesn't work for NNTP servers which never prompt you for a password change. There's no way to add a password in that case. Oct 6, 2013 at 2:33
  • @KarlthePagan - This doesn't depend on the server, it's a Thunderbird feature to store the password required by the server. This doesn't change the password on any server (mail or news), only the password stored in thunderbird. If you want to change your NNTP password, you will need to change it on the NNTP server, not in Thunderbird (and after in thunderbird also using this answer).
    – laurent
    Oct 6, 2013 at 14:42
  • @laurent I am never prompted for a password for news.grc.com, see instructions here grc.com/discussions.htm Oct 11, 2013 at 20:43
1

This is how I did it, I am using Thunderbird version 2.0.0.22 but the process may work similarly for newer versions:

1) Open Thunderbird

2) Click: Tools - Options - Edit saved passwords

3) Delete sites related to email accounts

4) Restart Thunderbird

5) At prompt, enter new password that you have established with your internet provider.

1
  • in windows, after passwords are cleared, sometimes is required change the account name to email address otherwise you will receive "authentication failed" error (( no matter if password is set correctly )) Feb 22, 2014 at 5:25
0

Open up Tools -> Account Settings. Scroll / Go dooown to the bottom of that left box. You can see an "Outgoing server (SMTP)" line. Click on it. Now, select your account and delete it.

enter image description here

enter image description here

(If you still can't find it, warning: You may have to check the other menus also. Like Edit. If I remember clearly on Linux it's under a different tab.)

4
  • There is no "Account Settings" under "Tools". However, I can find the "Account Settings" under "Edit" and it has the related "Outgoing server (SMTP)" -line. There are checkboxes for "Use name and password" and "Use secure authentication" and field for a user name but no field for passwords. Jul 20, 2010 at 10:44
  • Well. I thought I'd make pictures but its so simple, one cant mess up. :D >> See edit.
    – Apache
    Jul 20, 2010 at 11:49
  • Removing the account does not help because: "when I click Enter New Password, no password prompt appears" Jul 20, 2010 at 12:12
  • 1
    The problem is not with the account, it is with the memorized password.
    – laurent
    Jul 20, 2010 at 12:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.