If I am watching a video file, press stop then wait for the screensaver to kick in, the video file will restart from where it was stopped but the screen will remain blank, i.e. the audio will be playing - annoying.

Although I'm not sure when this started, it has been happening for a while (certainly longer than any system restore points I have) so I'm presuming some update caused this.

Is there anything I can do to stop this, short of a full OS reinstall?

Fully updated Vista Home Premium SP2 with GeForce 7650GS running current WHQL driver.

Edit: Here's a timeline of what happens:

  • Playing video normally
  • Press stop. Video & audio stop, play menu appears on screen
    [screensaver delay]
  • Screensaver kicks in, video resumes playing automatically but 'behind' screensaver

Edit 2: This doesn't happen with recorded TV, only with playback of other video files.

  • The problem arrives with what : Screensaver or sleep/hibernate? Do you mean that there is no video after it, or that the audio doesn't stop during it? – harrymc Aug 3 '10 at 11:08
  • Updated question. Not sure why I put suspend in there, the system never goes to sleep :/ – Lunatik Aug 3 '10 at 15:09

Is your cursor a non-standard one ?
If yes, try setting it to a normal and simple cursor.

Also, make sure that your system is fully patched (also for optional updates).
And turn off the Media Center screensaver.


The following Microsoft Support article may pertain to the problem:
When you use full-screen mode to watch video in Windows Media Center, the screen saver may start on a Windows Vista-based computer

The workaround is :

  • In Power Options enable the Don't require a password setting
  • In Screen Saver clear the On resume, display logon screen check box

The article Screensaver of doom offers a 3rd one:

  • Turn off Fast User Switching


Some more ideas:

  • Open Windows Media Player and select menu Tools -> Options.
    Check "Allow screen saver during playback" under the Player tab.
  • Don't use a screen saver.
    Use instead Control Panel -> Power Options to turn off the monitor and/or sleep.


Since you say that this doesn't happen with recorded TV, this can be a codec problem.

If you have installed any codecs, singly or in packs, you might try uninstalling and installing another one.

I personally prefer the K-Lite Codec Pack, which also has one of the best installers.


A utility for listing all codecs on the computer is NirSoft's InstalledCodec :

InstalledCodec is a small utility displays the list of all Codec drivers and DirectShow filters currently installed on your system. For each component the following information is displayed: Display Name, Type, Disabled Status, Installed/Modified Time, Description, Company Name, Filename, and more...
It allows you to easily disable or enable any Codec/DirectShow component or export the list into text/xml/html file.

  • Normal cursor (spinning blue circle). The screensaver is one of the Windows ones (floating clock text). System is pretty much fully updated through Windows Update, including most optional updates. There are a couple that I've not allowed (updates for Office compatibility etc.) as I've run into problems with them in the past. Can't see how they would make any difference in this instance though. – Lunatik Aug 4 '10 at 6:26
  • @Lunatik: See my edit. – harrymc Aug 4 '10 at 9:06
  • Password/logon on resume from screensaver is off already. Fast user switching is already disabled. – Lunatik Aug 4 '10 at 13:32
  • @Lunatik: See my 2nd edit. – harrymc Aug 4 '10 at 20:10
  • Just wanted to say IMO, I like shark007.net as the codec pack. Anyway, that's another option if going k-lite fails. – crazysim Aug 8 '10 at 10:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.