0

I tried to set the option “Local Computer Policy->Computer Configuration->Administrative Templates->Windows Components->Windows Update->No auto-restart for scheduled Automatic Update installation” to Enable, but my Windows 10 machine still restarts automatically after the update.

enter image description here

Why doesn't this option work?

What is the right way to prevent the restart after update?

5
  • 1
    “What is the right way to prevent the restart after update?” - Disable Allow Automatic Installation immediate installation and set activity hours. You can do that by configuring ** Turn off auto-restart for updates during active hours**; What version of Windows 10 are you running? Configuring ** Specify deadline before auto-restart for update installation** also is helpful – Ramhound Jun 11 at 23:34
  • 1
    @John - I issued the downvote to your answer, it was factually incorrect, since you indicated you could NOT prevent the automatic installation of Windows Updates (that absolutely can be done). The second reason is the fact your factually incorrect inaccurate statement was commentary since it absolutely does not and the author’s question. As for the reason I didn’t comment under your answer, I knew you would delete it, without attempting to improve it. When I see factually incorrect and inaccurate answers I will downvote them. Undelete and improve and the downvote disappears! – Ramhound Jun 11 at 23:49
  • @Ramhound see my Windows version: developernote.com/wp-content/uploads/2021/06/image-16.png. The question is correct and your second comment is strange. – Dmitriano Jun 13 at 23:49
  • It might be strange without the context of the comment or the answer but it was an accurate statement. As for your image, why isn’t it included in the body of your question, you should use the upload image feature. @John had submitted a comment suggested something I strongly disagreed with (which I will only share with a moderator). – Ramhound Jun 14 at 0:37
  • I mentioned several other policies that should also be enabled to nearly guarantee you will be notified of the automatic reboot of a pending Windows Update. My personal machine does not automatically reboot, so I know Windows 10 21H1 can be configured, to notify the user of the installation of a pending update. My answer directly addresses the question that was asked – Ramhound Jun 14 at 0:49
3

Why doesn't this option work?

The reason the policy isn’t being applied is due to the fact Configure Automatic Updates isn’t enabled.

No auto-restart with logged on users for scheduled automatic updates installations

Use this policy to prevent automatic restart when a user is logged on. This policy applies only when the Configure Automatic Updates policy is configured to perform scheduled installations of updates.

Source: Here

What is the right way to prevent the restart after update?

You have to enable both policies to be prompted to install updates. However, the better way to install updates, is to defer updates for a period of time, and routinely update your machine once a week.

3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.