0

tl;dr version

  • Site works on all other machines on same network
  • Site gives ‘connection reset’ error on all browsers on problematic machine
  • All other websites work fine on problematic machine as well
  • Site worked until around 1 PM today; didn’t work around 4 PM (machine not touched in between)
  • Can ping site from problematic machine
  • Reboot when it stopped working installed pending Windows update
  • Troubleshooting tool finds no issues
  • Fiddling with DNS, proxies, firewall, etc. has no effect

 


 

More detailed version

Starting this afternoon, one particular website will not open on my dad’s desktop computer: it loads for about five to ten seconds or so, and then consistently fails with a ‘connection reset’ error (ERR_CONNECTION_RESET).

The machine is an older PC running Windows 10.

The site loads just fine in any browser on my laptop, as well as on everyone’s phones and on another even older desktop machine also running Windows 10 – all are the same wireless network. On my dad’s desktop, though, it won’t load in any browser (well, Edge, Firefox and Chrome, those are the ones installed).

All other sites that we’ve tried work perfectly fine on the machine, including ones that he has probably never visited before (so they’re definitely not loading from cache), and pinging the problematic site also works just fine, with no packet loss. The site is one he uses daily, and it worked fine around 1 o’clock this afternoon; a few hours later, nada. No one had touched the machine in the intervening hours.

One of the first things we did when it wouldn’t work was to reboot the machine, at which point a pending update to Windows 10 was also installed; after that, the website worked, so we figured the pending update had been the culprit (somehow). But after a couple of minutes, it went back to not loading with the ‘connection reset’ error. This has since been reproduced: rebooting will make it work for a minute or two, but then it stops working again. The other Windows 10 machine (where the site works) has not had the update installed yet.

There is no antivirus stuff running, apart from Windows Defender, and nothing in the firewall. There’s no proxy. I’ve tried disabling and enabling stuff here, with no effect. I’ve also tried switching DNS servers to Google’s and CloudFlare (both in the system-wide network settings and in Chrome’s settings), which made no difference. I’ve run the Internet connection troubleshooting tool, which found no issues.

This Microsoft Answers question seems to describe an identical issue, but the answer that’s marked as correct is less than helpful. The suggestions are all browser-specific (not relevant, since this happens on all browsers), things I’ve already tried, or overly heavy-handed and intrusive (restoring to a restore point, resetting all network settings, etc.), and I don’t want to go through that unless it’s absolutely necessary.

What’s left to try? What can possibly be causing this lack of cooperation between one specific computer and one specific website?

2
  • Reboot your NAT gateway just in case it has a stale dynamic mapping that's causing problems.
    – Spiff
    Jun 20 at 7:15
  • @Spiff The only NAT gateway I have access to (I think?) is the wireless router. We did reboot that as well, which I forgot to mention in the question. Strangely, it looks like it’s back to working again this morning, so I suppose it must have been some sort of cached something or other that eventually got flushed somewhere… Jun 20 at 7:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.