I am installing fsl.
In a brandnew vps with Debian10, the command works perfectly.
wget -O- http://neuro.debian.net/lists/buster.au.full | sudo tee /etc/apt/sources.list.d/neurodebian.sources.list sudo apt-key adv --recv-keys --keyserver hkp://pool.sks-keyservers.net:80 0xA5D32F012649A5A9 sudo apt-get update sudo apt-get install fsl-core
However, when I try to install it on my own computer(exactly the same version of Debian10), it says
The following packages have unmet dependencies: fsl-5.0-core : Depends: libnifti2 but it is not installable Recommends: fsl-5.0-eddy-nonfree but it is not installable Recommends: fslview but it is not installable E: Unable to correct problems, you have held broken packages.
I recall that when I install fail2ban a month ago, I used aptitude instead of apt-get, aptitude suggeests to downgrade some packages, I followed that. I suspect the unmet dependencies is related to those downgraded packages. Since I only install a few softwares on my computer, including debian-desktop, vncserver, two anti-virus software, and fail2ban. Except fail2ban, the others were installed by apt-get.
However, after removing fail2ban, I still can not install fsl. I use aptitude to find out the details
sudo aptitude install fsl-core
The following packages have unmet dependencies: libnifticdf2 : Breaks: libnifti2 (<= 3.0) but 2.0.0+git186-g84740c2-1 is to be installed libniftiio2 : Breaks: libnifti2 (<= 3.0) but 2.0.0+git186-g84740c2-1 is to be installed
By the way, the error message is confusing, it requires libnifti2<=3.0, and the to-be-installed is 2.0, apprently the requirement is satisfied. I don't why this would break the dependency.
Is there any way that I can revert the downgraded packages caused by aptitude?