When I start Windows, my external USB hard disk does not appear at all: enter image description here

When I unplug and plug it in again, it appears normally and stays that way:

What I checked already is that Windows does a clean shutdown/start by uncheking the fast startup:

enter image description here

Unforunately that does not help. I also unchecked that Windows might power down this specific USB port:

enter image description here

At last, I also deactivated selective energy saving for USB in the energy settings:

enter image description here

The USB hard disk also does not show up in Disk Management nor USB Tree Viewer nor the BIOS:

enter image description here

enter image description here

enter image description here

Now I am running out of options what to do. Any ideas how I can make Windows recognize this hard disk right from the start?

  • 1
    You have done most of the troubleshooting by yourself. I also eager to know the answer.
    – Robert
    Jun 23 at 5:18
  • Have you done any other troubleshooting steps like trying a different USB port? Also, next time you start up the computer and the drive isn't showing up, run disk management and see if the drive is detected in there. I assume your drive is powered via USB?
    – NetServOps
    Jun 23 at 5:19
  • 2
    Just for curiosity sake, does the drive show up in your EFI firmware settings (aka BIOS) at boot without plug/unplug? This sounds more like a firmware bug to me than anything else. Also, before unplug/replug, try this tool and see what it shows. Bonus!! Es ist auf Deutsch! If the USB tool can't see it, windows can't either. Jun 23 at 5:24
  • @NetServOps I have not tried a different USB port, I can do that. However, I had my previous USB disk at the very same USB (3) port... it does not get recognized in disk management either (see additional screenshot in the description)... yes, via USB
    – Cyman
    Jun 25 at 10:37
  • @SeñorCMasMas I'll check the BIOS next time I reboot. The disk does show as "not connected" with the USB Tree Viewer (added screenshot)
    – Cyman
    Jun 25 at 10:41

I tried these two steps suggested (among many others) on https://www.online-tech-tips.com/computer-tips/usb-device-not-recognized/, and one (or both) of them solved my issue:

  1. After having replugged the USB device, I ejected it properly, disconnected it and connected it again
  2. I uninstalled all hidden USB devices

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.