0

Sorry for the block of text here guys, I'm just really stressed so I really appreciate your time and help!

I tried to install git for windows (MINGW64) for a tutorial I was doing yesterday. While doing the tutorial, git refused to let me do the initial push to my Github repo. I tried over and over again, looking for help online, but to no avail. The git push -u origin master command would just load forever in my git terminal, never actually succeeding in pushing my code to the repo. Eventually I gave up and went to do something else.

Later that night, I went to casually restart my computer and then spent 30 minutes panicking and trying to get out of BSOD, because my computer 'could not start correctly.' I fixed it by choosing the startup repair option or something, but when I finally logged in, something was clearly wrong. I got Windows notifications saying some of my apps would not open. My Discord tried to open but ultimately failed with a "Fatal JavaScript Error" window, which could only be fixed by uninstalling and reinstalling the program. When I open my VSCode this morning, I got the "Your Code installation appears to be corrupt. Please reinstall."

Clearly, whatever happened yesterday cause my laptop to break and is causing many of my programs to break as well. I had also enabled WSL2 earlier on in the day, but didn't actually restart my computer until later that night (when I got the BSOD), so I thought maybe it was that, but when I went to the system settings to turn off the 'Windows Hypervisor Platform' and 'Windows Subsystem for Linux' options, they were already unchecked (turned off). Looking online, there weren't many support requests regarding a link between enabling WSL2 and BSOD. I assumed this must not be the issue, then. (Unless you guys think it might be?)

Back to git- I decided it must be the culprit today when I tried to open it. Typing 'git' in my windows searchbar revealed an icon-less git.exe file (see images attached- blank git icon + broken .exe file). I cannot open this mysterious, seemingly-incomplete file no matter what I do. I remembered how it had failed to push my first commit changes to my remote repo, and decided I should just uninstall and reinstall it. When I went to the 'Add or Remove Programs' Windows feature, however, Git was not there. Doing some research online, I saw that I could look for the C:\Program Files\Git\unins001.exe executable and manually uninstall, but that file is just simply missing.Missing uninstall file in Git folder

tldr:, My computer and several important programs are breaking. I don't think its because I tried to enable WSL2, I think its because of some break in the Git ecosystem. It would load infinitely in the terminal when I tried an initial push to my Github repo (using the push -u origin master command), which I ran a number of times trying to make it work. Following BSOD after a restart later on, I cannot open or uninstall Git. It is invisible in my app settings and there is no uninstall .exe file that I can find.

Please help!!! I don't want to uninstall all these other programs, and fear for my life every time I restart my laptop.

7
  • 1
    This sounds a lot like your disk is on the verge of failure.
    – user1686
    Jun 23, 2021 at 16:49
  • Why? This laptop is brand new (a month old), and checking the task manager shows that my disk usage is very low (usually 0%, always 25%)
    – tprebenda
    Jun 23, 2021 at 17:10
  • New disks can fail. Jun 23, 2021 at 17:25
  • The solution to the broken applications is to simply reinstall them. There really isn't any other solution to the problems you describe
    – Ramhound
    Jun 23, 2021 at 18:06
  • @user168 I ran chkdsk on my SSD, it said there were no errors. Is there another way to ensure the stability of my disk?
    – tprebenda
    Jun 23, 2021 at 18:38

1 Answer 1

0

Well, it's not the answer you are looking for, but (as some of the comments are pointing out), reinstallation is probably going to be the best solution here, sorry to say.

What caused the problem in the first place? Again, it's not the answer you want to hear, but we may never know. Sometimes, sadly, software goes fubar due to some unexpected combination of circumstances. Perhaps someone will read your question, have the intuition to pose a theory on what happened, and be right. But sadly I just don't think that's going to happen given the details we see here. And I think it's going to be even more unlikely (given the number of applications and errors that you are experiencing) that someone will have a solution that doesn't involve reinstallation.

I also don't think that Git for Windows caused this. As far as I know, it's a fairly "unobtrusive" (for lack of a better word) piece of software. It doesn't change much of anything at the Windows level that could cause catastrophic failures like you are seeing.

There's a non-zero chance that your WSL2 install/config went bad somewhere along the way. Given that it does some deep hooks into Windows (primarily through Hyper-V), it has a chance of going wrong. Perhaps it didn't complete successfully, leaving the system in an unstable state, and that's why you don't see it enabled at this point. Again, we just don't know.

Side Note - I'm not trying to scare you away from WSL, and I hope this doesn't do so. I consider it a fantastic piece of engineering on Microsoft's part, personally, and it works for me beautifully on three separate computers.

Once you've been doing this for a while, honestly, reinstallation becomes a fact of life. Windows gets slower over time anyway, and a reinstall every year or two is typically needed to get rid of the "cruft" that builds up from software (including Windows patches) being installed, upgraded, uninstalled, etc. I know it's frustrating when it happens, but I recommend coming up with a game plan now for trying to make it as easy as possible to reinstall both now and the "next time". Because there will be a "next time".

I've been maintaining my "how I installed" list in Evernote for about a decade now. It contains the software I installed, along with any special configuration. I've even started configuring my WSL instances through Ansible, so that I can easily repeat it on each computer when I need to recover it.

Any personal files, of course, are backed up both to the cloud and to local offline storage.

If this is a new laptop with a near-manufacturer's install, you may be lucky enough to have a "Reset to Factory Image" (or something like that) option. After backing up, that can reset the primary partition to the "factory" state. Then reinstall any Windows Updates needed before proceeding with the other software installation.

Note that I tend to believe that this is a better option than the Windows "Reset". That option still leaves all of the installed programs on the drive, but simply removes the config/links from Windows. Better to really clean them off, IMHO.

If you don't have a factory reset, then you can download and reinstall Windows directly from Microsoft. Again, formatting the OS partition (after performing a backup) is probably the best bet, given the catastrophic failures you are seeing.

Could it be the drive? Possibly, but I tend to suspect the software first. If you reinstall and end up in this situation again, I'd contact the manufacturer and ask for a warranty replacement.

I'm really sorry to hear that this has happened, and wish I could provide a better answer for you.

1
  • Thank you so much for your response and your kindness throughout. My computer seems to be working fine now, so I guess I will just uninstall and reinstall the various programs that were being problematic after the BSOD. I've created a restore point in my system, and I have my important files backed up to OneDrive. I plan to try again to enable WSL (maybe WSL1 over WSL2, just in case), since I too have loved that feature on other laptops. I also will probably just delete my Git folder in my Program Files directory, and try to reinstall... Still, I am afraid of them both now haha
    – tprebenda
    Jun 23, 2021 at 21:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.