I have tried setting up an FTPS server to share uncut footage faster than sending it through Gmail. Every other post about this topic says the person mysteriously found this problem fixed the next day.

It works fine on my local network: FTPS Server IP: Listening Port: 21 Listening FTP over TLS Port: 990 I am using ports: 50000-51000 for passive ports.

I am able to connect to the server on a computer within my network, however, if I try to connect to it from outside my network, even though I have port forwarded ports 21,990 and 50000-51000 (Passive ports) it still will not let me connect from outside. I set up a few Windows Firewall rules and even disabled the firewall temporarily to see if that was causing the problem, but it still would not connect.

Every time I try to connect externally it either times out, or says:

"Connected on port 990, sending welcome message..."

Then times out 20 seconds later.

It also says not logged in even though I have triple-checked the username and password for the account.

Example: https://i.stack.imgur.com/haLJA.png

1 Answer 1


Apparently, it had something to do with my router's firewall, or that my router had a FTP server already running on port 21. I changed the port to 2121 and it worked.

https://ftptest.net is a life saver.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .