0

I'm REALLY new to Linux, so just bear with me... I downloaded a .tar.bz2 file, and I am trying to unpack it. However, each time I attempt to unpack the tarball using tar zxvf Linux says "Cannot open: No such file or directory." I've tried typing the file name in a bunch of different ways and I've tried unzipping the file. I don't know if I'm using the wrong code, or what, but I've been trying to use this file for an hour, and can't seem to unpack it. Thanks for your help...

Edit: Here is a screenshot:

enter image description here

here is one of ls directories

5
  • Use --bzip2 or -I as well. This option tells 'tar' to read or write archives through 'bzip2'.
    – DavidPostill
    Jun 30, 2021 at 17:29
  • A screenshot of what you're doing would be helpful.
    – harrymc
    Jun 30, 2021 at 17:51
  • @harrymc I added a screenshot...
    – bad-gyal
    Jun 30, 2021 at 18:07
  • try adding ./ before the filename or add the entire path to the file. Even then.. there isn't enough information.. we can't tell if you are in the same directory or what. Jun 30, 2021 at 18:08
  • Add a screenshot of ls in the directory could tell us that.
    – harrymc
    Jun 30, 2021 at 18:10

1 Answer 1

1

The issue is that a bz2 file is not a "gzip" file - which us what your extract command expects.

Im not near my computer to double check, but im fairly sure you need the -j flag rather then -z to decompress this with tar - try

  tar -jxvf repy-*.tar.bz2

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .