This is an isolated update to a previous question I asked regarding the same issue after a Windows update in June 2021.

I didn't take this advice and instead continued troubleshooting.

While trying to uninstall previous Windows updates, I found that the Tiworker.exe (Windows Modules Installer Worker) that had been showing abnormal behaviour was located in the folder of a recent update. Particularly, servicing stack 10.0.19041.1081 (and funnily, its installation date roughly matches when my computer broke down.)

Servicing stack 10.0.19041.1081 suspicious. How uninstall?

I tried uninstalling it, but it doesn't uninstall.

Now, wishfully thinking that I have nearly identified the problem, how can I uninstall this servicing stack?

EDIT: July 2021- Heeding @Ramhound and @syseng21, I reinstalled Windows on my PC and well, it is working. The lesson is to just reinstall Windows if it doesn't work.

EDIT: December 2022- Thanks to the brilliant efforts by @Henke, an in-place upgrade maybe a better(albeit, slower) option for most people. Here's the link to Henke's detailed guide to perform it.

  • 1
    You can't remove Service Stack updates they are required. You cannot remove the SSU from the system after installation.. The only way forward would be to perform an in-place repair with a Windows 10 ISO for 19041 (2004)
    – Ramhound
    Commented Jul 6, 2021 at 16:05
  • However, instead of reinstalling 2004 and having to upgrade to 20H2 with an enablement package, I would download an 21H1 ISO and upgrade to that. Of course this assumes your overall issue of being unable to delete any file off your SSD prevents that upgrade. If it does then a clean install is your only choice (which is a well documented procedure)
    – Ramhound
    Commented Jul 6, 2021 at 16:13
  • Ok so thanks @Ramhound for your interest...now lemme be quite frank...I can't reset or clean install my pc(my parents will not appreciate this coz these things have happened before due to my school's org I'd and....let's just leave it)..now can you please tell me about any repair commands or how can I do what you suggest without...just reinstalling windows...thanks and sorry for limiting the answer
    – Nerd951
    Commented Jul 6, 2021 at 16:27
  • The update you are asking about in this question cannot be removed. I am happy to submit that as an answer, but this question, is specifically about removing an update that cannot be removed. There is no fixing this problem without reinstalling Windows due to your other issue of being unable to delete anything on your SSD.
    – Ramhound
    Commented Jul 6, 2021 at 16:34
  • 1
    As a note, you can remove servicing stack updates with System Restore.
    – Danny
    Commented Mar 15, 2023 at 20:14

4 Answers 4


So, I tried uninstalling it

You can't remove Service Stack updates they are required to receive future updates through Windows Update.

Running Windows Update Standalone Installer (wusa.exe) with the /uninstall switch on the combined package will not work because the combined package contains the SSU. You cannot remove the SSU from the system after installation.

Source: June 21, 2021—KB5003690 (OS Builds 19041.1081, 19042.1081, and 19043.1081) Preview

Can anyone help me in uninstalling it

The Servicing Stack 10.0.19041.1081 cannot be uninstalled from your system. The only way forward would be to perform an in-place repair with a Windows 10 ISO for 19041 (2004). However, instead of reinstalling 2004 and having to upgrade to 20H2 with an enablement package, I would download an 21H1 ISO and upgrade to that. If the issue you describe with your SSD prevents you from performing an in-place upgrade then your only option is to do a clean install of Windows 10.


I found the solution!

Had the same problem as you've mentioned above. None of my programmes worked since the last update.

Found a site that helped me solve my problem! www.makeuseof.com

These instructions are also mentioned in the link that I listed above:

"Type Command Prompt (Admin) in the Start menu search bar, then right-click and select Run as administrator to open an elevated Command Prompt. Type the following command and press Enter: DISM /online /cleanup-image /restorehealth. Wait for the command to complete. The process can take up to 20 minutes, depending on your system's health. The process seems stuck at certain times, but wait for it to complete. When the process completes, type sfc /scannow and press Enter."

  • Thanks @elekxs for answering this question.....Well, I have already tried the following commands, my pc really got stuck tho.....I will try it again, see if it works and update here...Thanks
    – Nerd951
    Commented Jul 10, 2021 at 2:52
  • Hej! Nah, that solution was only temporary. What I just found out what happened to mine. I tried to uninstall my gpu overclock program and then it worked.
    – elekxs
    Commented Jul 11, 2021 at 5:07
  • 1
    I was skeptical of this answer but after Servicing Stack 10.0.19041.1161 crippled my computer I was desperate and decided to try it. (Simple commands like git status were taking 8-10 seconds to complete.) Your answer restored my machine to its normal speed. Thank you!
    – Jen Garcia
    Commented Sep 5, 2021 at 15:12

Run this below command prompt with admin privileges.
which will remove your the installed servicing stack update.

Command: dism /Online /Remove-Package /PackageName:Package_for_RollupFix~31bf3856ad364e35~amd64~~19041.1110.1.15

-- Raghav

  • Thanks for trying to answer @Thiruveedhula_Ravi_Kumar..but, I already reset my pc and need not try this anymore...but, will recommend this if someone else's pc gets stuck(god forbid) :))..Thanks
    – Nerd951
    Commented Jul 19, 2021 at 13:34

My computer broke down after a Windows 10 update

How I performed an in-place upgrade of Windows

– As I understand your screenshot, you can still log in and access Windows?
This was the case for me when Windows Update failed with an error.
I salvaged the situation by performing an in-place upgrade of Windows.
See my detailed description on how I did it.

My experience from removing servicing stacks

how can I uninstall this servicing stack?

According to Microsoft, once a servicing stack update is installed, it cannot be removed or uninstalled from the machine.

This is not literally true, as I've removed servicing stacks myself. But I don't recommend doing it.

I removed several servicing stacks. At first, I didn't notice any difference. But when I checked my Windows specifications, they said I now had version 2004 of Windows 10, although I had updated to 21H2 a few months earlier.

In almost all other respects, Windows was working normally. But when I finally decided to update Windows 10 to get version 21H2 back, it just didn't work.

What I experienced was:

  • DISM /Online /Cleanup-Image /RestoreHealth failed,
  • System Restore failed,
  • sfc /scannow failed, and – worst of all
  • Windows Update failed.

All of these problems were solved after I did the in-place upgrade of Windows.


  • 1
    I find this answer serendipitous as my computer has broken down again;)) I will surely give a try to the solution you recommend.
    – Nerd951
    Commented Nov 4, 2022 at 2:57
  • 1
    The details of how I performed an in-place upgrade of Windows are now in this answer. I don't want to put the same answer in more than one place. The other answer contains much more details than what I ever put here. Commented Dec 24, 2022 at 15:20
  • 1
    Took a look at that answer and it is a treasure trove of data...am gonna be incorporating it in the question...thanks for the heads up and a happy new year to you and your loved ones
    – Nerd951
    Commented Dec 26, 2022 at 15:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .