0

I'm trying to setup remote access for my home PC through ssh, FTP & VNC. Ssh is working, it's time for FTP. My "server" runs under Manjaro with vsftpd as FTP-server. First, I'm trying to access it with FileZilla from Win10 machine, here is connection log:

Status: Connecting to 192.168.50.10:21...
Status: Connection established, waiting for welcome message...
Status: Insecure server, it does not support FTP over TLS.
Status: Logged in
Status: Retrieving directory listing...
Command:    PWD
Response:   257 "/home/***" is the current directory
Command:    TYPE I
Response:   200 Switching to Binary mode.
Command:    PASV
Response:   227 Entering Passive Mode (192,168,50,10,127,51).
Command:    LIST
Error:  Transfer connection interrupted: ECONNABORTED - Connection aborted
Error:  Connection closed by server
Error:  Failed to retrieve directory listing

I made a port forwarding for FTP in my router and ran test from https://ftptest.net/, here is log:

Warning: Allowing fallback to plaintext FTP is insecure. You should use explicit FTP over TLS.
Status: Resolving address of ***
Status: Connecting to ***
Warning: The entered address does not resolve to an IPv6 address.
Status: Connected, waiting for welcome message...
Reply: 220 (vsFTPd 3.0.3)
Command: CLNT https://ftptest.net on behalf of ***
Reply: 530 Please login with USER and PASS.
Command: AUTH TLS
Reply: 530 Please login with USER and PASS.
Warning: Server refused AUTH TLS, trying deprecated AUTH SSL fallback.
Command: AUTH SSL
Reply: 530 Please login with USER and PASS.
Warning: Server refused AUTH SSL, falling back to insecure plaintext FTP.
Command: USER ***
Reply: 331 Please specify the password.
Command: PASS ******
Reply: 230 Login successful.
Command: SYST
Reply: 215 UNIX Type: L8
Command: FEAT
Reply: 211-Features:
Reply: EPRT
Reply: EPSV
Reply: MDTM
Reply: PASV
Reply: REST STREAM
Reply: SIZE
Reply: TVFS
Reply: UTF8
Reply: 211 End
Warning: The server does not indicate MLSD support. MLSD uses a well-specified listing format. Without MLSD, directory listings have to be obtained using LIST which uses an unspecified output format.
Command: PWD
Reply: 257 "/home/***" is the current directory
Status: Current path is /home/***
Command: TYPE I
Reply: 200 Switching to Binary mode.
Command: PASV
Reply: 227 Entering Passive Mode (*,*,*,*,43,142).
Command: LIST
Status: Data connection established.
Error: Could not read from socket: Connection reset by peer

ftptest.net says that this error is due

  • A common cause for this problem are broken routers and/or firewalls that interrupt the connection.
  • Some broken or badly configured servers can also interrupt the connection prematurely.

I disabled win10 firewall, router firewall, what can I check further?

UPDATE:

I'm trying to login as my Manjaro's user, so I think this user has all permissions to it's home dir. Anyway, I tried to set permissions 777 to home dir - it didn't help. Also I added my user to vsftpd.userlists and added this file to vsftpd.config - still no luck.

I noted in sudo systemctl status vsftpd that

vsftpd[14483]: pam_listfile(vsftpd:auth): Couldn't open /etc/ftpusers

so I created it, and added my user here. Now FileZilla says:

Response: 530 Login incorrect.

, but I'm sure my user and it's password are correct, so I deleted my user from /etc/ftpusers and now I have the same errors as before except missing /etc/ftpusers.

I'm complete newbie in net technologies, so I'm just tried to establish sftp session in Mobaxterm, unsuccessfully:

Connection error: unable to connect to server

UPDATE 2:

I'am still unable to setup FTP, but SFTP works well, so I've accepted the answer.

1
  • I'd check your FTP server config, and make sure the user in question has access to the directory in question. Jul 7, 2021 at 22:50

1 Answer 1

1

If you can run ssh then sftp is available. It's just like FTP but with ssh's inbuilt security. The interface looks just the same.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .