9

I have a problem with my Windows 7 desktop.

Everything works fine, except that it can't goes sleep, when I try to make it sleeps (clicking on "Sleep" on the start menu), it just locks the session (It does like if I clicked on "lock"),

I have no problems with the Sleep mode with Linux on the same computer... Nothing appear in the event logs (except some services start/stop when it try to sleep)

I also see that when I try to make it sleep, I have some USB-related errors (Communication Failure on my USB UPS, and the screen on my Logitech G15 shows nothing until I restart the services)

It worked at the begin, I don't know why it stopped working.. I would prefer to not format just for this....

I tried to unplug all the USB devices (except the mouse) and disabling as the possible services, that don't change anything..

Any ideas please ?

Thank you

4
  • It happened on a friend of mine's PC when he started to use some kind of "Loader". Do you use such a thing or is it a totally legal/valid Win? (Don't worry we won't rape you if it's not legal but this is a common case.)
    – Apache
    Jul 21, 2010 at 22:57
  • Nop, I own a legal Windows licence
    – Kedare
    Jul 22, 2010 at 0:57
  • I am currently having this problem after fixing my MBRs. This happens on dual boot systems if the proper partition is not marked active etc. I am stuck! I fixed the MBR to get hibernate working. Now I neither have sleep nor have nibernate :-(
    – Lord Loh.
    Oct 23, 2012 at 2:12
  • 1
    I can confirm that it is dual boot related. Win7 cannot sleep when I boot from my ubuntu disk through grub, but when I boot directly (using the option in the BIOS) to the Win7 disk the pc sleeps normally.
    – qwazix
    May 3, 2013 at 11:27

3 Answers 3

9

Check your power settings by running through this list (especially make sure the hybrid sleep mode is disabled):

http://www.vistax64.com/tutorials/63567-power-options-sleep-mode-problems.html

It is for Vista, but it applies to Windows 7 (to a degree).

3
  • Thank you very much ! The problem has been fixed by disabling Hybrid sleep mode.
    – Kedare
    Jul 22, 2010 at 13:52
  • 1
    You are very welcome! I had this same issue back in Vista. Very frustrating. However they did finally get 'sleep' right in Vista/7 and I use it all the time. Jul 22, 2010 at 14:07
  • same problem in windows 7 ultimate sp1 x64 and yes, it works great for windows 7 sp1. Microsoft still has sleep disabled by default, should be on. it's hibernation that's dangerous and can make your filesystem disappear if you remove or connect a device between suspend and resume. that's a no-no. instead, for hibernation, leave things plugged in the way they are and resist the urge to tinker it's NOT in the same state as powered off. if you see the message "could not write $MFT" then filesystem is irretrievable. I tried partition/file recovery programs. Sep 17, 2014 at 8:39
1

I managed to get my sleep working with the free software Sleep.exe. Be sure to use it with the /f switch

1

I have one sugesstion. If system has multiboot, boot dirctly from desired Hard disk which has win OS instead of bootloader (such as grub). It works for me!! I have two HD, Ubuntu and Win 7 (Win1) in one of them and Win 7 on the other(Win2). When I boot from Grub and choose Win1, It goes to sleep but when choose Win2, It doesn't go to sleep. I chaged boot priority (It may also with F8 on boot level and choose the secdond HD) and saw this time Win 2 goes to sleep!! Try!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.