I have a Lenovo Ideapad L340, with a Realtek 8822be Wireless Adapter. It works flawlessly with Windows, but completely fails on Linux, which I'm trying to have on a dual boot. So I could neither connect to the internet or to any bluetooth devices on Linux. But, I recently tried out Garuda Linux, and the bluetooth is somehow working perfectly well. Although the wifi issues persist, the bluetooth issues seem to be fixed by just installing Garuda Linux.

But, the thing is that Garuda Linux is waaaay to bloated and slow, and gives a very bad battery life. And unfortunately, in Garuda's barebones edition, which has none of the bloat, the bluetooth doesn't work.

So, I've been trying to reproduce the bluetooth fix in another installation of regular Arch, but I really don't know where to start. So I was hoping somebody could help.

Thank you!!!

Note 1: I've already tried Ubuntu, Kali and Pop before switching to Garuda

Note 2: Please let me know, if any more details are required and I'll promptly add them.

Thanks again!!!

  • 1
    Check the Lenovo site for a new Bluetooth driver for you machine. There was a new one for my machine in the last 7 days. This is not the same as your machine, but there may be a new driver for your machine and if so, see if one for Linux, and re-check the Realtek site.
    – John
    Jul 19, 2021 at 1:24
  • 1
    Ubuntu has support for that chip but additional drivers must be installed. Jul 19, 2021 at 1:29
  • @ChanganAuto, do you by chance have a link where I can find them? And thanks for the quick response. Jul 19, 2021 at 2:24
  • 1
  • 1
    @GauravChandan Look at bbs.archlinux.org/viewtopic.php?id=260589. It looks almost exactly like the same problem as yours.
    – funilrys
    Jul 19, 2021 at 18:13


You must log in to answer this question.

Browse other questions tagged .