I'm currently running Windows 11 and The microphone was working fine when I first updated, fast-forward to now, I put my computer on sleep mode then come back the next day to find my microphone not working at all. I have the "Tronsmart Glary Gaming Headset" and its of type USB input, not aux cord input/line-in input. Windows still detects that there is a microphone connected. However, It doesn't detect any sound input at all on any program. Here is what i tried to do to fix it and failed:

  • Went to Device Manager; Uninstalled then reinstalled the microphone
  • Went to Device Manager; Tried Updating the drivers and Re-installing it
  • Tried to update the headphone drivers externally
  • Tried to update overall sound drivers but all are up-to-date
  • Unplugging and Re-plugging my headphones
  • Restarting my PC
  • Going to sound settings and making sure its Detected in the settings, Volume set to 100% and Tried to troubleshoot and came up with nothing

What's strange is when I join any type of call, lets say a Discord Call or Telegram Call or Whatever, Windows displays to me that Its currently using my microphone in the system tray on the bottom right-hand side. So I figured I'd try another microphone, Line-In this time. So i grabbed it and connected it to the back of my PC in the microphone slot and to my surprise it didn't work either, however this time it doesn't detect it at all. I thought maybe its interfering with my headphones (even though it never did that before) so I unplugged them and still windows doesn't detect it at all. So now, I have no clue what the issue is and it was working fine less than 12 hours ago.

1 Answer 1


Something similar happened to me, like for a moment it is working then boom. Microphone is not working.

Have you tried going System > Sound > Input (Microphone Array)

Then make sure that the Input Volume is decent because in my case it just went to 0 without no reason. Looking at you Windows 11.

enter image description here

  • Thanks for the response. However, this post is almost a year old but I do appreciate it and I have purchased a new microphone :) And to answer your question, yes, I have tried that also, the issue was with the microphone itself, it was worn out physically.
    – PackOf20
    Jun 9, 2022 at 20:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.