2

I want to format my E: partition, but from the disk manager menu its disabled, and access is denied from powershell.

Image of drive and partitions.

How do I get this to work?

1
  • 2
    I know little about Windows, but your problem may be because the page file is there. Can you move it out of the way? What Windows is it? Jul 25 at 22:54
3

A partition with the pagefile cannot be formatted or deleted. You first need to disable the pagefile, or move it to another disk. If you wish the pagefile to be on the formatted E, disable it now and re-enable after the format. You should not stay permanently without having any pagefile, only temporarily.

  • Run Control Panel > System
  • Click "Advanced system settings"
  • Navigate to the "Advanced" tab
  • Under Performance, click Settings
  • Navigate to the Advanced tab
  • Under Virtual memory, click Change
  • Untick "Automatically manage paging..."
  • Select drive E: and click 'No paging file'
  • Click Set
  • Click OK on all.

You may, the same way, pick C: as the disk for housing a new pagefile.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.