Every couple of days our HP WHS box disappears from the network until I manually cycle its power. It's plugged into a gigabit switch, along with the rest of our computers. All it's lights are on, including the NIC light. It also responds to ping. I can't connect to it with RDC, the built-in software, and the shares are no longer available. It is running the latest 3.0 version of the software.

Has this happened to anyone else?

3 Answers 3


Has happened to me as well. In my case, if I waited long enough, the console would load and I could shut down a few things.

I permanently disabled a few different services related to HP's media streaming feature: twonkey.exe and firefly.exe (rdc to the server as administrator and with password you use to connect to the console. run Services.msc and stop then disable those two services.)

You may also notice that QSM and Demigrator are using a lot of CPU. Do not mess with them.

I'm not certain, but my problems (and possibly yours) could stem from an HDD going bad. A few different SMART tools tell me my bad sector count on my system drive is getting up there. You should check your drives as well.

To check SMART status on WHS, I use Home Server SMART: http://www.dojonorthsoftware.net/Freebies/HomeServerSMART.aspx plugin. SpeedFan: http://www.almico.com/speedfan.php provides more insight, but must be installed/run on the server itself (not as a plug-in.)

  • So disabling those services helped? I'll give it a try. Can you recommend a SMART tool?
    – travis
    Jan 19, 2011 at 4:28
  • Yes, disabling those services has helped, but I don't have a really good reason, aside from possible pending disk failure, why they should have started acting up. Added links to the SMART tools I use.
    – CCrawford
    Jan 24, 2011 at 18:45
  • Same thing happened to me. I was recycling it every few days for a few months, then finally the HD died completely. I didn't know why it kept dropping the network, but I suspect the HD was on its way out.
    – mohlsen
    Jan 19, 2012 at 12:44

I had exactly the same issue. very simple solution in the end. The network card was set to auto-negotiate and was netotiating half-duplex. Setting the network card to 100mbps full duplex has solved my problem and the server is now working better than ever.

  • Interesting, I'll definitely have to try this one.
    – travis
    Apr 1, 2011 at 5:06
  • Well so far, it's still disappearing after making the change in the driver properties. :-( Was there anything else that you changed?
    – travis
    Apr 5, 2011 at 15:48

The solution I went with is a huge hack, but it works. I first tried adding a restart event into the scheduled tasks, which worked fine for a few days. Then I noticed that it still disappeared off of the network and stopped restarting. So I bought one of those outlet timers and just set it to cut the power from 6am - 6:15am. Probably not the best thing for the hardware, but it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.